summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/eglfs/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Mutz <marc.mutz@qt.io>2023-07-12 08:48:19 +0200
committerMarc Mutz <marc.mutz@qt.io>2023-08-02 14:02:33 +0200
commitc91146b9eff65cd8c860d26e09242795300a6b14 (patch)
tree843f0da41ae1146546254f32ba8fee13aa03f6b3 /src/plugins/platforms/eglfs/CMakeLists.txt
parent923790832777f3e4d9d9be5eba13a9ffdedcf9e7 (diff)
eglfs plugin: port away from Q_FOREACH
Mark the module are Q_FOREACH-free, so it stays that way. These two instances are risk-free, because the loop is over local variables that the loop bodies clearly do not touch, so the safety copy that Q_FOREACH takes is not required here. Pick-to: 6.6 Change-Id: Ida3c1d51c661d77a59a2ad105e080c3c9b66c53f Reviewed-by: Shawn Rutledge <shawn.rutledge@qt.io>
Diffstat (limited to 'src/plugins/platforms/eglfs/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/eglfs/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/plugins/platforms/eglfs/CMakeLists.txt b/src/plugins/platforms/eglfs/CMakeLists.txt
index cebb0fe66e..58c45e466a 100644
--- a/src/plugins/platforms/eglfs/CMakeLists.txt
+++ b/src/plugins/platforms/eglfs/CMakeLists.txt
@@ -34,6 +34,7 @@ qt_internal_add_module(EglFSDeviceIntegrationPrivate
DEFINES
QT_BUILD_EGL_DEVICE_LIB
QT_EGL_NO_X11
+ QT_NO_FOREACH
EGLFS_PREFERRED_PLUGIN=${QT_QPA_DEFAULT_EGLFS_INTEGRATION}
INCLUDE_DIRECTORIES
api