summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/eglfs/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-11-13 15:00:38 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-11-14 09:05:48 +0000
commite9a58ba9e55467f8c69e19dd52c2afa7cbb39529 (patch)
tree0d9d92641192c7bc7ca7c6d451d7d123d80ea6bb /src/plugins/platforms/eglfs/CMakeLists.txt
parent38354d7d6132344a322751c91202109d847771b9 (diff)
Regenerate src/*
Change-Id: I0314b4faa1e4860e86198eea4189987e527dfec2 Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/plugins/platforms/eglfs/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/eglfs/CMakeLists.txt12
1 files changed, 6 insertions, 6 deletions
diff --git a/src/plugins/platforms/eglfs/CMakeLists.txt b/src/plugins/platforms/eglfs/CMakeLists.txt
index 8a3c77a5ac..2dde32b0f3 100644
--- a/src/plugins/platforms/eglfs/CMakeLists.txt
+++ b/src/plugins/platforms/eglfs/CMakeLists.txt
@@ -5,7 +5,7 @@ qt_find_package(EGL) # special case
## EglFSDeviceIntegration Module:
#####################################################################
-add_qt_module(EglFSDeviceIntegration
+qt_add_module(EglFSDeviceIntegration
INTERNAL_MODULE
SOURCES
api/qeglfsdeviceintegration.cpp api/qeglfsdeviceintegration_p.h
@@ -40,14 +40,14 @@ add_qt_module(EglFSDeviceIntegration
## Scopes:
#####################################################################
-extend_target(EglFSDeviceIntegration CONDITION TARGET Qt::InputSupportPrivate
+qt_extend_target(EglFSDeviceIntegration CONDITION TARGET Qt::InputSupportPrivate
LIBRARIES
Qt::InputSupportPrivate
PUBLIC_LIBRARIES
Qt::InputSupport
)
-extend_target(EglFSDeviceIntegration CONDITION TARGET Qt::PlatformCompositorSupportPrivate
+qt_extend_target(EglFSDeviceIntegration CONDITION TARGET Qt::PlatformCompositorSupportPrivate
LIBRARIES
Qt::PlatformCompositorSupportPrivate
PUBLIC_LIBRARIES
@@ -65,7 +65,7 @@ if(QT_FEATURE_cursor) # special case
"cursor.json"
)
- add_qt_resource(EglFSDeviceIntegration "cursor"
+ qt_add_resource(EglFSDeviceIntegration "cursor"
PREFIX
"/"
FILES
@@ -73,7 +73,7 @@ if(QT_FEATURE_cursor) # special case
)
endif()
-extend_target(EglFSDeviceIntegration CONDITION QT_FEATURE_opengl
+qt_extend_target(EglFSDeviceIntegration CONDITION QT_FEATURE_opengl
SOURCES
api/qeglfscontext.cpp api/qeglfscontext_p.h
api/qeglfscursor.cpp api/qeglfscursor_p.h
@@ -82,7 +82,7 @@ extend_target(EglFSDeviceIntegration CONDITION QT_FEATURE_opengl
## qeglfs Plugin:
#####################################################################
-add_qt_plugin(qeglfs
+qt_add_plugin(qeglfs
TYPE platforms
CLASS_NAME QEglFSIntegrationPlugin
DEFAULT_IF ${QT_QPA_DEFAULT_PLATFORM} MATCHES eglfs # special case