summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/eglfs/deviceintegration/eglfs_kms/CMakeLists.txt
diff options
context:
space:
mode:
authorElvis Lee <kwangwoong.lee@lge.com>2020-11-05 18:22:02 +0900
committerElvis Lee <kwangwoong.lee@lge.com>2020-11-17 22:11:08 +0900
commit0decd926adf239ed48ccf984140b15fb304805a3 (patch)
tree4198f97c1c12825a008f05ba1c7234355084cf27 /src/plugins/platforms/eglfs/deviceintegration/eglfs_kms/CMakeLists.txt
parent2e3b8b36f7aa43991b44bc6b048c713b0a013a57 (diff)
Correct headers to build with eglfs modules
To build with eglfs module and gbm device integration module, some headers should consider global path, not local. This covers eglfs_kms and eglfs_kms_egldeivce device integration. Other device integrations might be future work if needed. Task-number: QTBUG-85268 Change-Id: I1bad5fbac99aa79d146e90f88b53519b09254e13 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Laszlo Agocs <laszlo.agocs@qt.io> Reviewed-by: Elvis Lee <kwangwoong.lee@lge.com>
Diffstat (limited to 'src/plugins/platforms/eglfs/deviceintegration/eglfs_kms/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/eglfs/deviceintegration/eglfs_kms/CMakeLists.txt3
1 files changed, 0 insertions, 3 deletions
diff --git a/src/plugins/platforms/eglfs/deviceintegration/eglfs_kms/CMakeLists.txt b/src/plugins/platforms/eglfs/deviceintegration/eglfs_kms/CMakeLists.txt
index 44ddebbf9b..19169981d1 100644
--- a/src/plugins/platforms/eglfs/deviceintegration/eglfs_kms/CMakeLists.txt
+++ b/src/plugins/platforms/eglfs/deviceintegration/eglfs_kms/CMakeLists.txt
@@ -15,9 +15,6 @@ qt_internal_add_module(EglFsKmsGbmSupport
qeglfskmsgbmwindow.cpp qeglfskmsgbmwindow_p.h
DEFINES
QT_EGL_NO_X11
- INCLUDE_DIRECTORIES
- ../../api
- ../eglfs_kms_support
PUBLIC_LIBRARIES
Libdrm::Libdrm
Qt::CorePrivate