summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/offscreen/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2019-03-29 12:35:08 +0100
committerTobias Hunger <tobias.hunger@qt.io>2019-03-29 14:37:14 +0000
commit2d1bc2dd6f5663d3e25974ab3746194df0a1cdeb (patch)
treeab513a58ba4806d4c652ac970cc456202791e96a /src/plugins/platforms/offscreen/CMakeLists.txt
parentdde95a3bdb14e4c71a9284671b8eb67347fa488f (diff)
CMake: Re-generate plugins/platforms/offscreen
Change-Id: Ie26bed794881835278f3874e318d00affad8aa05 Reviewed-by: Albert Astals Cid <albert.astals.cid@kdab.com>
Diffstat (limited to 'src/plugins/platforms/offscreen/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/offscreen/CMakeLists.txt21
1 files changed, 10 insertions, 11 deletions
diff --git a/src/plugins/platforms/offscreen/CMakeLists.txt b/src/plugins/platforms/offscreen/CMakeLists.txt
index d5bff05451..1cb5f0a456 100644
--- a/src/plugins/platforms/offscreen/CMakeLists.txt
+++ b/src/plugins/platforms/offscreen/CMakeLists.txt
@@ -1,7 +1,5 @@
# Generated from offscreen.pro.
-find_package(X11)
-
#####################################################################
## qoffscreen Plugin:
#####################################################################
@@ -17,14 +15,16 @@ add_qt_plugin(qoffscreen
QT_NO_FOREACH
LIBRARIES
Qt::CorePrivate
- Qt::GuiPrivate
Qt::EventDispatcherSupportPrivate
Qt::FontDatabaseSupportPrivate
- # OTHER_FILES = "offscreen.json"
- # PLUGIN_CLASS_NAME = "QOffscreenIntegrationPlugin"
- # _LOADED = "qt_plugin"
+ Qt::GuiPrivate
)
+#### Keys ignored in scope 1:.:offscreen.pro:<NONE>:
+# OTHER_FILES = "offscreen.json"
+# PLUGIN_CLASS_NAME = "QOffscreenIntegrationPlugin"
+# _LOADED = "qt_plugin"
+
## Scopes:
#####################################################################
@@ -35,11 +35,10 @@ extend_target(qoffscreen CONDITION QT_FEATURE_opengl AND QT_FEATURE_xlib AND NOT
Qt::GlxSupportPrivate
)
-extend_target(qoffscreen CONDITION NOT QT_FEATURE_opengl OR QT_FEATURE_opengles2 OR NOT QT_FEATURE_xlib
+extend_target(qoffscreen CONDITION QT_FEATURE_opengles2 OR NOT QT_FEATURE_opengl OR NOT QT_FEATURE_xlib
SOURCES
qoffscreenintegration_dummy.cpp
)
-#
-#extend_target(qoffscreen CONDITION NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN
-# # PLUGIN_EXTENDS = "-"
-#)
+
+#### Keys ignored in scope 4:.:offscreen.pro:NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN:
+# PLUGIN_EXTENDS = "-"