summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/vnc/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-02-03 19:44:27 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-02-05 14:36:31 +0000
commitac38fa11823f4cf020a9481c9de3d61caa8fccdc (patch)
treec7a07940738e7015cb43e28f97b9f2bde794b039 /src/plugins/platforms/vnc/CMakeLists.txt
parentc5b61d2e90fde5d9f2e968f4443ca393e52393f5 (diff)
Regenerate projects to correctly handle private dependencies
Change-Id: I7d84bc9962bff5c89a90367ae704974c6ce2ec89 Reviewed-by: Qt CMake Build Bot Reviewed-by: Leander Beernaert <leander.beernaert@qt.io> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/plugins/platforms/vnc/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/vnc/CMakeLists.txt18
1 files changed, 5 insertions, 13 deletions
diff --git a/src/plugins/platforms/vnc/CMakeLists.txt b/src/plugins/platforms/vnc/CMakeLists.txt
index 502cff06db..cb84355d81 100644
--- a/src/plugins/platforms/vnc/CMakeLists.txt
+++ b/src/plugins/platforms/vnc/CMakeLists.txt
@@ -16,23 +16,17 @@ qt_add_plugin(QVncIntegrationPlugin
qvncscreen.cpp qvncscreen.h
DEFINES
QT_NO_FOREACH
- LIBRARIES
+ PUBLIC_LIBRARIES
+ Qt::Core
Qt::CorePrivate
Qt::EventDispatcherSupportPrivate
Qt::FbSupportPrivate
Qt::FontDatabaseSupportPrivate
+ Qt::Gui
Qt::GuiPrivate
+ Qt::Network
Qt::ServiceSupportPrivate
Qt::ThemeSupportPrivate
- PUBLIC_LIBRARIES
- Qt::Core
- Qt::EventDispatcherSupport
- Qt::FbSupport
- Qt::FontDatabaseSupport
- Qt::Gui
- Qt::Network
- Qt::ServiceSupport
- Qt::ThemeSupport
)
#### Keys ignored in scope 1:.:.:vnc.pro:<TRUE>:
@@ -42,10 +36,8 @@ qt_add_plugin(QVncIntegrationPlugin
#####################################################################
qt_extend_target(QVncIntegrationPlugin CONDITION TARGET Qt::InputSupportPrivate
- LIBRARIES
- Qt::InputSupportPrivate
PUBLIC_LIBRARIES
- Qt::InputSupport
+ Qt::InputSupportPrivate
)
#### Keys ignored in scope 3:.:.:vnc.pro:NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN: