summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/vnc/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-01-22 14:23:02 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-01-27 11:49:34 +0000
commitb10d8eab047c387409716ae87422d2efffee3159 (patch)
treef5ce14f553e5b8de3b2ebda30965ce4f5df380d6 /src/plugins/platforms/vnc/CMakeLists.txt
parent604aa83ad910c3a17af33850312d3c61a59f558f (diff)
Regenerate plugin projects to get new target names
And also to get the original output names (qmake's "TARGET"), so that the plugin file names are as they were in Qt 5. Change-Id: I96a060d1a81693652847857372bec334728cb549 Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/plugins/platforms/vnc/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/vnc/CMakeLists.txt8
1 files changed, 4 insertions, 4 deletions
diff --git a/src/plugins/platforms/vnc/CMakeLists.txt b/src/plugins/platforms/vnc/CMakeLists.txt
index 0b5295287b..502cff06db 100644
--- a/src/plugins/platforms/vnc/CMakeLists.txt
+++ b/src/plugins/platforms/vnc/CMakeLists.txt
@@ -1,12 +1,12 @@
# Generated from vnc.pro.
#####################################################################
-## qvnc Plugin:
+## QVncIntegrationPlugin Plugin:
#####################################################################
-qt_add_plugin(qvnc
+qt_add_plugin(QVncIntegrationPlugin
+ OUTPUT_NAME qvnc
TYPE platforms
- CLASS_NAME QVncIntegrationPlugin
DEFAULT_IF ${QT_QPA_DEFAULT_PLATFORM} MATCHES vnc # special case
SOURCES
main.cpp
@@ -41,7 +41,7 @@ qt_add_plugin(qvnc
## Scopes:
#####################################################################
-qt_extend_target(qvnc CONDITION TARGET Qt::InputSupportPrivate
+qt_extend_target(QVncIntegrationPlugin CONDITION TARGET Qt::InputSupportPrivate
LIBRARIES
Qt::InputSupportPrivate
PUBLIC_LIBRARIES