summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/vnc/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Hausmann <simon.hausmann@qt.io>2019-06-05 13:48:02 +0200
committerSimon Hausmann <simon.hausmann@qt.io>2019-06-05 14:20:26 +0000
commitbc9409d85748c7167a9e8e7eec82fa6c9420ea3d (patch)
treea2f431d606578dd67c53b5fba14cdf8611b02e78 /src/plugins/platforms/vnc/CMakeLists.txt
parent9298033ed6e6e67cce89243f44b7ce77018d0e62 (diff)
Re-generate the CMakeLists.txt and add the prev files
Change-Id: I93ea196bdd5807bccebf81e72332966288a35a4f Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/plugins/platforms/vnc/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/vnc/CMakeLists.txt35
1 files changed, 24 insertions, 11 deletions
diff --git a/src/plugins/platforms/vnc/CMakeLists.txt b/src/plugins/platforms/vnc/CMakeLists.txt
index ced972391d..8a294a09fb 100644
--- a/src/plugins/platforms/vnc/CMakeLists.txt
+++ b/src/plugins/platforms/vnc/CMakeLists.txt
@@ -6,6 +6,7 @@
add_qt_plugin(qvnc
TYPE platforms
+ CLASS_NAME QVncIntegrationPlugin
SOURCES
main.cpp
qvnc.cpp qvnc_p.h
@@ -16,26 +17,38 @@ add_qt_plugin(qvnc
QT_NO_FOREACH
LIBRARIES
Qt::CorePrivate
- Qt::Network
+ Qt::EventDispatcherSupportPrivate
+ Qt::FbSupportPrivate
+ Qt::FontDatabaseSupportPrivate
Qt::GuiPrivate
Qt::ServiceSupportPrivate
Qt::ThemeSupportPrivate
- Qt::FbSupportPrivate
- Qt::EventDispatcherSupportPrivate
- Qt::FontDatabaseSupportPrivate
- # OTHER_FILES = "vnc.json"
- # PLUGIN_CLASS_NAME = "QVncIntegrationPlugin"
- # _LOADED = "qt_plugin"
+ PUBLIC_LIBRARIES
+ Qt::Core
+ Qt::EventDispatcherSupport
+ Qt::FbSupport
+ Qt::FontDatabaseSupport
+ Qt::Gui
+ Qt::Network
+ Qt::ServiceSupport
+ Qt::ThemeSupport
)
+#### Keys ignored in scope 1:.:.:vnc.pro:<TRUE>:
+# OTHER_FILES = "vnc.json"
+# PLUGIN_CLASS_NAME = "QVncIntegrationPlugin"
+# PLUGIN_TYPE = "platforms"
+# _LOADED = "qt_plugin"
+
## Scopes:
#####################################################################
extend_target(qvnc CONDITION TARGET Qt::InputSupportPrivate
LIBRARIES
Qt::InputSupportPrivate
+ PUBLIC_LIBRARIES
+ Qt::InputSupport
)
-#
-#extend_target(qvnc CONDITION NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN
-# # PLUGIN_EXTENDS = "-"
-#)
+
+#### Keys ignored in scope 3:.:.:vnc.pro:NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN:
+# PLUGIN_EXTENDS = "-"