summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/wasm/CMakeLists.txt
diff options
context:
space:
mode:
authorMorten Sørvig <morten.sorvig@qt.io>2022-06-09 13:10:03 +0200
committerMorten Sørvig <morten.sorvig@qt.io>2022-07-06 17:56:58 +0200
commit9be0f2945d404ceb743e4805f7df388c7fd039f1 (patch)
tree652ea4510f4b1a3ce674364063d4f1b0877ccfb7 /src/plugins/platforms/wasm/CMakeLists.txt
parent25c2d05340eee01cf55457b8327f8f69d408879a (diff)
wasm: begin work on accessibility backend
Implement a11y support by adding html elements of the appropriate type and/or with the appropriate ARIA attribute behind the canvas. Also add a simple manual-test. Change-Id: I2898fb038c1d326135a1341cdee323bc964420bb Reviewed-by: Lorn Potter <lorn.potter@gmail.com>
Diffstat (limited to 'src/plugins/platforms/wasm/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/wasm/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/plugins/platforms/wasm/CMakeLists.txt b/src/plugins/platforms/wasm/CMakeLists.txt
index efd468c9be..113dad18c6 100644
--- a/src/plugins/platforms/wasm/CMakeLists.txt
+++ b/src/plugins/platforms/wasm/CMakeLists.txt
@@ -11,6 +11,7 @@ qt_internal_add_plugin(QWasmIntegrationPlugin
STATIC
SOURCES
main.cpp
+ qwasmaccessibility.cpp qwasmaccessibility.h
qwasmclipboard.cpp qwasmclipboard.h
qwasmcompositor.cpp qwasmcompositor.h
qwasmcursor.cpp qwasmcursor.h