summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/windows/CMakeLists.txt
diff options
context:
space:
mode:
authorFriedemann Kleint <Friedemann.Kleint@qt.io>2020-05-29 11:03:49 +0200
committerFriedemann Kleint <Friedemann.Kleint@qt.io>2020-06-15 20:58:35 +0200
commitb89d8c406b5809f868f1a06d9ab05096ecb226f3 (patch)
tree6a3d072cc76769daf6914eb1fe906d6b9501fb11 /src/plugins/platforms/windows/CMakeLists.txt
parentf626c73b28b52ecf3a3fb20592f2134337f89d35 (diff)
Windows font databases: Enable DirectWrite for cmake
- Remove the DirectWrite1,2 features. Windows 10 should have them, only MinGW is missing directwrite3. The feature directwrite now implies DirectWrite2. - Remove the custom defines. - Port over the configure tests from configure.json and add missing ones for DirectWrite(2), DirectWrite3 and Direct2D and Direct2D 1.1, fix the conditions and report them in the summary. Task-number: QTBUG-83255 Fixes: QTBUG-83931 Change-Id: I1fc68997adc715bd5c6d7ec457f58c46e1f81c6a Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/plugins/platforms/windows/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/windows/CMakeLists.txt8
1 files changed, 1 insertions, 7 deletions
diff --git a/src/plugins/platforms/windows/CMakeLists.txt b/src/plugins/platforms/windows/CMakeLists.txt
index 9674710d54..9064b2f740 100644
--- a/src/plugins/platforms/windows/CMakeLists.txt
+++ b/src/plugins/platforms/windows/CMakeLists.txt
@@ -91,13 +91,7 @@ qt_extend_target(QWindowsIntegrationPlugin CONDITION QT_FEATURE_opengl
Qt::OpenGLPrivate
)
-qt_extend_target(QWindowsIntegrationPlugin CONDITION QT_FEATURE_directwrite3
- DEFINES
- QT_USE_DIRECTWRITE2
- QT_USE_DIRECTWRITE3
-)
-
-#### Keys ignored in scope 4:.:.:windows.pro:NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN:
+#### Keys ignored in scope 3:.:.:windows.pro:NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN:
# PLUGIN_EXTENDS = "-"
qt_extend_target(QWindowsIntegrationPlugin CONDITION QT_FEATURE_opengl AND NOT QT_FEATURE_dynamicgl