summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/windows/CMakeLists.txt
diff options
context:
space:
mode:
authorAmir Masoud Abdol <amir.abdol@qt.io>2023-03-29 12:05:21 +0200
committerAmir Masoud Abdol <amir.abdol@qt.io>2023-04-03 12:41:14 +0200
commited4d2917ae5a391ab1a4b6a98d75eae90fa37f32 (patch)
treea52f8f2eecfabc705a49423cc244f5d5645614ba /src/plugins/platforms/windows/CMakeLists.txt
parent7e074bd8a0d0137043cf43aa2473d0c3082fe3be (diff)
Use NO_PCH_SOURCES to exclude files
We should be able to just use NO_PCH_SOURCES under MINGW condition and get the same result. P.S. The problem with `qwindowspointerhandler.cpp`, most likely caused due to symbol collision with `qwindowsmousehandler.cpp`. We've encountered it again when we were building with unity. Pick-to: 6.5 Change-Id: I20a5091d5d1a329228b5ddb4694f5fd61d803554 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'src/plugins/platforms/windows/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/windows/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/src/plugins/platforms/windows/CMakeLists.txt b/src/plugins/platforms/windows/CMakeLists.txt
index abbcebfcfc..333b7d67f1 100644
--- a/src/plugins/platforms/windows/CMakeLists.txt
+++ b/src/plugins/platforms/windows/CMakeLists.txt
@@ -102,6 +102,8 @@ qt_internal_extend_target(QWindowsIntegrationPlugin CONDITION QT_FEATURE_opengl
qt_internal_extend_target(QWindowsIntegrationPlugin CONDITION MINGW
LIBRARIES
uuid
+ NO_PCH_SOURCES
+ qwindowspointerhandler.cpp
)
qt_internal_extend_target(QWindowsIntegrationPlugin CONDITION QT_FEATURE_systemtrayicon
@@ -197,7 +199,3 @@ qt_internal_extend_target(QWindowsIntegrationPlugin CONDITION MINGW AND QT_FEATU
LIBRARIES
uuid
)
-
-if (MINGW)
- set_source_files_properties(qwindowspointerhandler.cpp PROPERTIES SKIP_PRECOMPILE_HEADERS ON)
-endif()