summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/xcb/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-05-29 18:07:31 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-05-29 23:22:47 +0200
commit77771116a4d43e4832494785bc0abde8f3d8fd58 (patch)
treeda36c5c63a63697243b1c8044b55be20dc8b1ae5 /src/plugins/platforms/xcb/CMakeLists.txt
parenta9fbe539669d6b22b6d790b02b73e40f1b9ede06 (diff)
CMake: Regenerate src/plugins
Change-Id: Icceceeb42023e7fa5edf320bb21f03d11bd357b7 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io>
Diffstat (limited to 'src/plugins/platforms/xcb/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/xcb/CMakeLists.txt18
1 files changed, 9 insertions, 9 deletions
diff --git a/src/plugins/platforms/xcb/CMakeLists.txt b/src/plugins/platforms/xcb/CMakeLists.txt
index 6e4388cc3f..65c085ff10 100644
--- a/src/plugins/platforms/xcb/CMakeLists.txt
+++ b/src/plugins/platforms/xcb/CMakeLists.txt
@@ -81,12 +81,6 @@ qt_extend_target(XcbQpa CONDITION TARGET Qt::LinuxAccessibilitySupportPrivate
Qt::LinuxAccessibilitySupportPrivate
)
-qt_extend_target(XcbQpa CONDITION QT_FEATURE_vulkan
- SOURCES
- qxcbvulkaninstance.cpp qxcbvulkaninstance.h
- qxcbvulkanwindow.cpp qxcbvulkanwindow.h
-)
-
qt_extend_target(XcbQpa CONDITION QT_FEATURE_glib
LIBRARIES
GLIB2::GLIB2
@@ -115,6 +109,12 @@ qt_extend_target(XcbQpa CONDITION QT_FEATURE_xcb_sm
${X11_SM_LIB} ${X11_ICE_LIB}
)
+qt_extend_target(XcbQpa CONDITION QT_FEATURE_vulkan
+ SOURCES
+ qxcbvulkaninstance.cpp qxcbvulkaninstance.h
+ qxcbvulkanwindow.cpp qxcbvulkanwindow.h
+)
+
qt_extend_target(XcbQpa CONDITION QT_FEATURE_dlopen
PUBLIC_LIBRARIES
${CMAKE_DL_LIBS}
@@ -166,7 +166,7 @@ endif()
## QXcbIntegrationPlugin Plugin:
#####################################################################
-qt_add_plugin(QXcbIntegrationPlugin
+qt_internal_add_plugin(QXcbIntegrationPlugin
OUTPUT_NAME qxcb
TYPE platforms
DEFAULT_IF ${QT_QPA_DEFAULT_PLATFORM} MATCHES xcb # special case
@@ -180,13 +180,13 @@ qt_add_plugin(QXcbIntegrationPlugin
Qt::XcbQpaPrivate
)
-#### Keys ignored in scope 20:.:.:xcb-plugin.pro:<TRUE>:
+#### Keys ignored in scope 19:.:.:xcb-plugin.pro:<TRUE>:
# OTHER_FILES = "xcb.json" "README"
## Scopes:
#####################################################################
-#### Keys ignored in scope 22:.:.:xcb-plugin.pro:NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN:
+#### Keys ignored in scope 21:.:.:xcb-plugin.pro:NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN:
# PLUGIN_EXTENDS = "-"
add_subdirectory(gl_integrations)
if(OFF)