summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/xcb/CMakeLists.txt
diff options
context:
space:
mode:
authorAllan Sandfeld Jensen <allan.jensen@qt.io>2020-10-29 15:31:14 +0100
committerAllan Sandfeld Jensen <allan.jensen@qt.io>2020-10-29 18:09:24 +0100
commitb77cf10a4fbe328fd8b7e0bd0294813dc6394773 (patch)
tree392fd39be1e7807801099a952e00afb52caa4152 /src/plugins/platforms/xcb/CMakeLists.txt
parent743ffcbc822cc46c2b2d7cde6b6a3eca303d5c60 (diff)
Move QPolygonClipper to XCB native painting
It is the only code using it. Change-Id: I30060a63b6621ea94ae487ec93cd857117e12a46 Reviewed-by: Eirik Aavitsland <eirik.aavitsland@qt.io>
Diffstat (limited to 'src/plugins/platforms/xcb/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/xcb/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/plugins/platforms/xcb/CMakeLists.txt b/src/plugins/platforms/xcb/CMakeLists.txt
index 6d6b76a641..e4af25458e 100644
--- a/src/plugins/platforms/xcb/CMakeLists.txt
+++ b/src/plugins/platforms/xcb/CMakeLists.txt
@@ -120,6 +120,7 @@ qt_internal_extend_target(XcbQpa CONDITION QT_FEATURE_xcb_native_painting
nativepainting/qcolormap_x11.cpp nativepainting/qcolormap_x11_p.h
nativepainting/qpaintengine_x11.cpp nativepainting/qpaintengine_x11_p.h
nativepainting/qpixmap_x11.cpp nativepainting/qpixmap_x11_p.h
+ nativepainting/polygonclipper_p.h
nativepainting/qt_x11_p.h
nativepainting/qtessellator.cpp nativepainting/qtessellator_p.h
nativepainting/qxcbnativepainting.cpp nativepainting/qxcbnativepainting.h