summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/xcb/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2019-05-07 16:38:55 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-05-07 17:10:20 +0000
commite8bb67330164e3ed4baf87b4b0a46d584fe3b738 (patch)
tree74f29deb8f903d2200d06c37eb73216eff19b0c9 /src/plugins/platforms/xcb/CMakeLists.txt
parentaa8af1283f92033a615f0f2325b841100a303d92 (diff)
CMake: Regenerate xcb platform plugin
This contains fixes to the improved library detection recently introduced. Change-Id: I5df03b0c965dd0b8cf4b1769c752ecbb81558265 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/plugins/platforms/xcb/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/xcb/CMakeLists.txt22
1 files changed, 10 insertions, 12 deletions
diff --git a/src/plugins/platforms/xcb/CMakeLists.txt b/src/plugins/platforms/xcb/CMakeLists.txt
index 57ec1b9443..c6c0c90b25 100644
--- a/src/plugins/platforms/xcb/CMakeLists.txt
+++ b/src/plugins/platforms/xcb/CMakeLists.txt
@@ -1,6 +1,6 @@
-# Generated from xcb_qpa_lib.pro.
+# Generated from xcb.pro.
-# special case:
+# begin special case:
qt_find_package(X11_XCB)
qt_find_package(X11)
qt_find_package(XCB)
@@ -10,6 +10,7 @@ qt_find_package(Freetype)
qt_find_package(GLIB2)
pkg_check_modules(XKB_COMMON_X11 xkbcommon-x11>=0.4.1 IMPORTED_TARGET) # special case
+# end special case:
#####################################################################
## XcbQpa Module:
@@ -55,6 +56,7 @@ add_qt_module(XcbQpa
Qt::ServiceSupportPrivate
Qt::ThemeSupportPrivate
Qt::XkbCommonSupportPrivate
+ PkgConfig::XKB_COMMON_X11 # special case
PUBLIC_LIBRARIES
${CMAKE_DL_LIBS}
Qt::Core
@@ -79,7 +81,7 @@ add_qt_module(XcbQpa
XKB::XKB
)
-#### Keys ignored in scope 1:.:.:xcb_qpa_lib.pro:<TRUE>:
+#### Keys ignored in scope 3:.:.:xcb_qpa_lib.pro:<TRUE>:
# CONFIG = "no_module_headers" "internal_module"
# _LOADED = "qt_build_paths" "qt_module"
@@ -158,16 +160,13 @@ extend_target(XcbQpa CONDITION QT_FEATURE_xcb_native_painting
extend_target(XcbQpa CONDITION QT_FEATURE_xcb_native_painting AND QT_FEATURE_xrender
PUBLIC_LIBRARIES
- X11::Xrender # special case
+ PkgConfig::xrender
)
extend_target(XcbQpa CONDITION QT_FEATURE_fontconfig AND QT_FEATURE_xcb_native_painting
LIBRARIES
Freetype::Freetype
)
-
-# Generated from xcb-plugin.pro.
-
#####################################################################
## qxcb Plugin:
#####################################################################
@@ -188,7 +187,7 @@ add_qt_plugin(qxcb
Qt::XcbQpa
)
-#### Keys ignored in scope 1:.:.:./xcb-plugin.pro:<TRUE>:
+#### Keys ignored in scope 24:.:.:xcb-plugin.pro:<TRUE>:
# OTHER_FILES = "xcb.json" "README"
# PLUGIN_CLASS_NAME = "QXcbIntegrationPlugin"
# _LOADED = "qt_plugin"
@@ -196,12 +195,11 @@ add_qt_plugin(qxcb
## Scopes:
#####################################################################
-#### Keys ignored in scope 2:.:.:./xcb-plugin.pro:APPLE_OSX:
+#### Keys ignored in scope 25:.:.:xcb-plugin.pro:APPLE_OSX:
# CONFIG = "no_app_extension_api_only"
-#### Keys ignored in scope 3:.:.:./xcb-plugin.pro:NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN:
+#### Keys ignored in scope 26:.:.:xcb-plugin.pro:NOT TARGET___equals____ss_QT_DEFAULT_QPA_PLUGIN:
# PLUGIN_EXTENDS = "-"
-
add_subdirectory(gl_integrations)
-#### TODO: xcb-static sub folder
+#### TODO: xcb-static sub folder # special case