summaryrefslogtreecommitdiffstats
path: root/src/plugins/platforms/xcb/gl_integrations/xcb_glx/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-11-13 15:00:38 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-11-14 09:05:48 +0000
commite9a58ba9e55467f8c69e19dd52c2afa7cbb39529 (patch)
tree0d9d92641192c7bc7ca7c6d451d7d123d80ea6bb /src/plugins/platforms/xcb/gl_integrations/xcb_glx/CMakeLists.txt
parent38354d7d6132344a322751c91202109d847771b9 (diff)
Regenerate src/*
Change-Id: I0314b4faa1e4860e86198eea4189987e527dfec2 Reviewed-by: Qt CMake Build Bot Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/plugins/platforms/xcb/gl_integrations/xcb_glx/CMakeLists.txt')
-rw-r--r--src/plugins/platforms/xcb/gl_integrations/xcb_glx/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/plugins/platforms/xcb/gl_integrations/xcb_glx/CMakeLists.txt b/src/plugins/platforms/xcb/gl_integrations/xcb_glx/CMakeLists.txt
index ede38c9837..dfb74d7138 100644
--- a/src/plugins/platforms/xcb/gl_integrations/xcb_glx/CMakeLists.txt
+++ b/src/plugins/platforms/xcb/gl_integrations/xcb_glx/CMakeLists.txt
@@ -4,7 +4,7 @@
## qxcb-glx-integration Plugin:
#####################################################################
-add_qt_plugin(qxcb-glx-integration
+qt_add_plugin(qxcb-glx-integration
TYPE xcbglintegrations
CLASS_NAME QXcbGlxIntegrationPlugin
SOURCES
@@ -33,12 +33,12 @@ add_qt_plugin(qxcb-glx-integration
## Scopes:
#####################################################################
-extend_target(qxcb-glx-integration CONDITION QT_FEATURE_xcb_glx
+qt_extend_target(qxcb-glx-integration CONDITION QT_FEATURE_xcb_glx
PUBLIC_LIBRARIES
XCB::GLX
)
-extend_target(qxcb-glx-integration CONDITION QT_FEATURE_dlopen AND NOT static
+qt_extend_target(qxcb-glx-integration CONDITION QT_FEATURE_dlopen AND NOT static
PUBLIC_LIBRARIES
${CMAKE_DL_LIBS}
)