summaryrefslogtreecommitdiffstats
path: root/src/plugins/platformthemes/CMakeLists.txt
diff options
context:
space:
mode:
authorAlbert Astals Cid <albert.astals.cid@kdab.com>2019-02-11 16:27:26 +0100
committerAlbert Astals Cid <albert.astals.cid@kdab.com>2019-02-11 17:16:28 +0000
commitac96d08b9d0900a8e368c2e72c86190335480911 (patch)
tree8cc2ea0fc9bb4b84797f5bc8ffaf050ddf03d98f /src/plugins/platformthemes/CMakeLists.txt
parent3726b58d3b7c595291c8a3f22ee518dffc382950 (diff)
cmake: find gtk3 and build the gtk3 platformtheme
Change-Id: I7db7321a2fd5ea0eda1924f3dece3b1c86d87d10 Reviewed-by: Tobias Hunger <tobias.hunger@qt.io>
Diffstat (limited to 'src/plugins/platformthemes/CMakeLists.txt')
-rw-r--r--src/plugins/platformthemes/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/plugins/platformthemes/CMakeLists.txt b/src/plugins/platformthemes/CMakeLists.txt
new file mode 100644
index 0000000000..5c65be8ce7
--- /dev/null
+++ b/src/plugins/platformthemes/CMakeLists.txt
@@ -0,0 +1,10 @@
+# Generated from platformthemes.pro.
+
+if (QT_FEATURE_dbus AND QT_FEATURE_regularexpression)
+# TODO add_subdirectory(xdgdesktopportal)
+endif()
+
+if (QT_FEATURE_widgets AND QT_FEATURE_gtk3)
+ add_subdirectory(gtk3)
+endif()
+