summaryrefslogtreecommitdiffstats
path: root/src/plugins/styles/windowsvista/CMakeLists.txt
diff options
context:
space:
mode:
authorLeander Beernaert <leander.beernaert@qt.io>2020-01-14 11:19:45 +0100
committerLeander Beernaert <leander.beernaert@qt.io>2020-01-14 12:37:25 +0000
commit0761715f791a3b8d529521e2c0ac7ba462d55e03 (patch)
tree475d2ca15417ce6c0a8c037fe4ab6ca55d1ee2c4 /src/plugins/styles/windowsvista/CMakeLists.txt
parent1f2cdd8a04938ca8fa9df090a85c5d689df4c049 (diff)
Regenerate src/
Change-Id: Icef5e834a6acc1cc4488bbed7749e81e1f2388b3 Reviewed-by: Qt CMake Build Bot Reviewed-by: Cristian Adam <cristian.adam@qt.io>
Diffstat (limited to 'src/plugins/styles/windowsvista/CMakeLists.txt')
-rw-r--r--src/plugins/styles/windowsvista/CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/src/plugins/styles/windowsvista/CMakeLists.txt b/src/plugins/styles/windowsvista/CMakeLists.txt
index 3304150c3e..bbb9210f10 100644
--- a/src/plugins/styles/windowsvista/CMakeLists.txt
+++ b/src/plugins/styles/windowsvista/CMakeLists.txt
@@ -13,11 +13,12 @@ qt_add_plugin(qwindowsvistastyle
qwindowsvistastyle_p_p.h
qwindowsxpstyle.cpp qwindowsxpstyle_p.h
qwindowsxpstyle_p_p.h
+ INCLUDE_DIRECTORIES
+ ../3rdparty/wintab
LIBRARIES
Qt::WidgetsPrivate
gdi32
user32
- uxtheme
PUBLIC_LIBRARIES
Qt::Core
Qt::Gui
@@ -26,3 +27,13 @@ qt_add_plugin(qwindowsvistastyle
#### Keys ignored in scope 1:.:.:windowsvista.pro:<TRUE>:
# DISTFILES = "windowsvistastyle.json"
+
+## Scopes:
+#####################################################################
+
+qt_extend_target(qwindowsvistastyle CONDITION NOT WINRT
+ LIBRARIES
+ dwmapi
+ shell32
+ uxtheme
+)