summaryrefslogtreecommitdiffstats
path: root/src/plugins/tls/certonly/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-07-06 18:24:10 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2021-07-07 09:41:37 +0200
commit434ada8dcb6132b3a597ea56b57a66c627f51728 (patch)
tree7ab60413cec030b06b15eb7b00462975a1ee4273 /src/plugins/tls/certonly/CMakeLists.txt
parent9e05e25acffd7ac327fda8c4a54c380b0753196b (diff)
CMake: Don't give plugins PUBLIC usage requirements
The pro2cmake.py conversion script faithfully reproduced the .pro files for the plugins, which specified the libraries as public. But in CMake, the implications of this are that public usage requirements should then be propagated to consumers. We don't expect any consumers, since a plugin is created as a MODULE library in CMake, so for Windows we don't even have an import library to link with. The only exception to this is for static builds where plugins are created as STATIC libraries instead, but only in certain controlled situations do we then link to plugins. Even then, usage requirements are not expected to propagate to the consumers, so these relationships should always be specified as private. Pick-to: 6.2 Task-number: QTBUG-90819 Change-Id: Ibc7c2bcd3b6a9dc77df40c4c0c22ff254a80f33d Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/plugins/tls/certonly/CMakeLists.txt')
-rw-r--r--src/plugins/tls/certonly/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/plugins/tls/certonly/CMakeLists.txt b/src/plugins/tls/certonly/CMakeLists.txt
index 275045dc49..1c8cc0de15 100644
--- a/src/plugins/tls/certonly/CMakeLists.txt
+++ b/src/plugins/tls/certonly/CMakeLists.txt
@@ -12,6 +12,6 @@ qt_internal_add_plugin(QTlsBackendCertOnlyPlugin
../shared/qasn1element.cpp
qtlsbackend_cert.cpp
qtlsbackend_cert_p.h
- PUBLIC_LIBRARIES
+ LIBRARIES
Qt::NetworkPrivate
)