summaryrefslogtreecommitdiffstats
path: root/src/printsupport/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-04-03 15:09:31 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-04-08 12:41:42 +0000
commit5691d2f47b19cde0cec76747ceca0a275292bfd0 (patch)
treeeb41c03d7508a19946ddd69e25fc7283b32365b8 /src/printsupport/CMakeLists.txt
parent867956a8432e16670c5ffdbcd97020622c58d08e (diff)
Fix yocto cross build
When cross-compiling Qt using a Yocto sysroot, if the sysroot already contains an installed Qt version, and a project (library or executable) does not explicitly link against all of its Qt dependencies, the cross linker will try to find a suitable library in the sysroot ./lib folder. This mighy lead to issues, because the linker will pick up an installed Qt library which might have different symbol versioning, and thus cause linker errors. This happened with the print support module. Make sure the print support module explicitly links against the newly built Qt modules. Task-number: QTBUG-74133 Change-Id: I876b1507c655673831e78dcfe737a5ede2a8c087 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/printsupport/CMakeLists.txt')
-rw-r--r--src/printsupport/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/printsupport/CMakeLists.txt b/src/printsupport/CMakeLists.txt
index 714859a8eb..b23a61e55d 100644
--- a/src/printsupport/CMakeLists.txt
+++ b/src/printsupport/CMakeLists.txt
@@ -29,6 +29,7 @@ add_qt_module(PrintSupport
Qt::WidgetsPrivate
PUBLIC_LIBRARIES # special case
Qt::Gui
+ Qt::Widgets
)
#### Keys ignored in scope 1:.:printsupport.pro:<NONE>: