summaryrefslogtreecommitdiffstats
path: root/src/printsupport/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2019-05-17 16:23:26 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-05-20 09:37:51 +0000
commit8cf45a6848525bd3d6e22468abf1362f51132d23 (patch)
tree917d220ddd0252b185da1460fa2b21f573c1c8bd /src/printsupport/CMakeLists.txt
parent17865396bf4e90adf2e6ca35c88bb815065e6cf1 (diff)
Regenerate printsupport
No .prev file cause it's a clean conversion. Change-Id: I33e02dccb9c8da336891c36cd0e1454d29152065 Reviewed-by: Tobias Hunger <tobias.hunger@qt.io>
Diffstat (limited to 'src/printsupport/CMakeLists.txt')
-rw-r--r--src/printsupport/CMakeLists.txt14
1 files changed, 8 insertions, 6 deletions
diff --git a/src/printsupport/CMakeLists.txt b/src/printsupport/CMakeLists.txt
index b23a61e55d..a689aa8d70 100644
--- a/src/printsupport/CMakeLists.txt
+++ b/src/printsupport/CMakeLists.txt
@@ -18,21 +18,22 @@ add_qt_module(PrintSupport
kernel/qprinterinfo.cpp kernel/qprinterinfo.h kernel/qprinterinfo_p.h
kernel/qtprintsupportglobal.h kernel/qtprintsupportglobal_p.h
DEFINES
- QT_NO_USING_NAMESPACE
QT_NO_FOREACH
+ QT_NO_USING_NAMESPACE
INCLUDE_DIRECTORIES
- widgets
dialogs
+ widgets
LIBRARIES
Qt::CorePrivate
Qt::GuiPrivate
Qt::WidgetsPrivate
- PUBLIC_LIBRARIES # special case
+ PUBLIC_LIBRARIES
+ Qt::Core
Qt::Gui
Qt::Widgets
)
-#### Keys ignored in scope 1:.:printsupport.pro:<NONE>:
+#### Keys ignored in scope 1:.:.:printsupport.pro:<TRUE>:
# MODULE_PLUGIN_TYPES = "printsupport"
# QMAKE_LIBS = "$$QMAKE_LIBS_PRINTSUPPORT"
# _LOADED = "qt_module"
@@ -143,5 +144,6 @@ extend_target(PrintSupport CONDITION QT_FEATURE_printpreviewdialog
SOURCES
dialogs/qprintpreviewdialog.cpp dialogs/qprintpreviewdialog.h
)
-
-add_qt_docs(./doc/qtprintsupport.qdocconf)
+add_qt_docs(
+ doc/qtprintsupport.qdocconf
+)