summaryrefslogtreecommitdiffstats
path: root/src/sql/CMakeLists.txt
diff options
context:
space:
mode:
authorVenugopal Shivashankar <Venugopal.Shivashankar@qt.io>2021-02-09 13:15:58 +0100
committerVenugopal Shivashankar <Venugopal.Shivashankar@qt.io>2021-02-10 21:19:15 +0100
commit746393545f6e68292b780ea62ea2f6bef81c708c (patch)
treec4df170c7024e917198f560a27682be32daa4300 /src/sql/CMakeLists.txt
parent1549dff04c49aa37333e54f8bc45900d0f35b270 (diff)
CMake: Port the snippet project setup to CMake
Change-Id: I411e58e94752f3b2d0a3e8aac0ab7c4c2272db89 Fixes: QTBUG-89826 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Paul Wicking <paul.wicking@qt.io> Reviewed-by: Edward Welbourne <edward.welbourne@qt.io>
Diffstat (limited to 'src/sql/CMakeLists.txt')
-rw-r--r--src/sql/CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/src/sql/CMakeLists.txt b/src/sql/CMakeLists.txt
index 43ec949fdd..3398b09a75 100644
--- a/src/sql/CMakeLists.txt
+++ b/src/sql/CMakeLists.txt
@@ -55,3 +55,8 @@ qt_internal_add_docs(Sql
doc/qtsql.qdocconf
)
+# include the snippet projects for developer-builds
+if(QT_FEATURE_private_tests)
+ add_subdirectory(doc/snippets/code)
+ add_subdirectory(doc/snippets/sqldatabase)
+endif()