summaryrefslogtreecommitdiffstats
path: root/src/sql/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2019-03-01 14:34:41 +0100
committerTobias Hunger <tobias.hunger@qt.io>2019-03-04 10:00:25 +0000
commitf3e3832c4dfcdc9148b414c4063668a9306e77ba (patch)
treeb7cac9b679e27d562361c867b91baca352d1c33f /src/sql/CMakeLists.txt
parent27fc264b7d7d89b29f809ffefb601b69bc1ddb4c (diff)
CMake: Re-generate CMakeLists.txt file for concurrent and sql
Change-Id: I3b61e35a65d369f0fff7c61c0b3af6f6e2974e1f Reviewed-by: Albert Astals Cid <albert.astals.cid@kdab.com>
Diffstat (limited to 'src/sql/CMakeLists.txt')
-rw-r--r--src/sql/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/sql/CMakeLists.txt b/src/sql/CMakeLists.txt
index ac4dd8f023..8581f80d01 100644
--- a/src/sql/CMakeLists.txt
+++ b/src/sql/CMakeLists.txt
@@ -24,6 +24,20 @@ add_qt_module(Sql
QT_NO_FOREACH
LIBRARIES
Qt::CorePrivate
+ PUBLIC_LIBRARIES # special case
+ Qt::Core
+ # MODULE_PLUGIN_TYPES = "sqldrivers"
+ # PRECOMPILED_HEADER = "../corelib/global/qt_pch.h"
+ # SQL_P = "sql"
+ # _LOADED = "qt_module"
+)
+
+## Scopes:
+#####################################################################
+
+extend_target(Sql CONDITION MSVC AND (TEST_architecture STREQUAL "i386")
+ LINK_OPTIONS
+ "/BASE:0x62000000"
)
extend_target(Sql CONDITION QT_FEATURE_sqlmodel