summaryrefslogtreecommitdiffstats
path: root/src/testlib/CMakeLists.txt
diff options
context:
space:
mode:
authorIvan Solovev <ivan.solovev@qt.io>2021-04-07 16:11:49 +0200
committerIvan Solovev <ivan.solovev@qt.io>2021-04-16 12:08:32 +0200
commit930e59b798d9e3d08e17440980d33a08fb411cbe (patch)
treeed60841dabd0fa1683790426c533659e6c2b9afe /src/testlib/CMakeLists.txt
parent7e15d57eb45ae7a873185c37f952b8c3a5f423dd (diff)
QTest: add helper methods to test bindable properties
This patch adds helper methods to test bindable properties in the QTest lib. These methods can be useful in many Qt modules, so we decided to have them in qtbase. For now they are in the private header, because we are not sure that they can be useful for the end users. Task-number: QTBUG-89874 Change-Id: I6738728df1bcd895758008ef2ade0d3693802c3e Reviewed-by: Edward Welbourne <edward.welbourne@qt.io> Reviewed-by: Juha Vuolle <juha.vuolle@insta.fi> Reviewed-by: Andreas Buhr <andreas.buhr@qt.io> Reviewed-by: Sona Kurazyan <sona.kurazyan@qt.io>
Diffstat (limited to 'src/testlib/CMakeLists.txt')
-rw-r--r--src/testlib/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/testlib/CMakeLists.txt b/src/testlib/CMakeLists.txt
index da53bb8b68..32e44c2d07 100644
--- a/src/testlib/CMakeLists.txt
+++ b/src/testlib/CMakeLists.txt
@@ -25,6 +25,7 @@ qt_internal_add_module(Test
qemulationdetector_p.h
qjunittestlogger.cpp qjunittestlogger_p.h
qplaintestlogger.cpp qplaintestlogger_p.h
+ qpropertytesthelper_p.h
qsignaldumper.cpp qsignaldumper_p.h
qsignalspy.h
qtaptestlogger.cpp qtaptestlogger_p.h