summaryrefslogtreecommitdiffstats
path: root/src/testlib/CMakeLists.txt
diff options
context:
space:
mode:
authorTobias Hunger <tobias.hunger@qt.io>2019-03-29 12:09:45 +0100
committerTobias Hunger <tobias.hunger@qt.io>2019-04-03 08:53:31 +0000
commite3b2ff001416f2f924143c6b79b7f67f9f7e2305 (patch)
tree5e47340d8bce6a501a8ae5423313acb3f2edc542 /src/testlib/CMakeLists.txt
parent1aff970c49713eb13bc3b8ace8dbdc4cb4a2f379 (diff)
CMake: Re-generate testlib
Change-Id: Id3e6a3ff325ed55ac20a93683260ef3366c0ddab Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/testlib/CMakeLists.txt')
-rw-r--r--src/testlib/CMakeLists.txt69
1 files changed, 46 insertions, 23 deletions
diff --git a/src/testlib/CMakeLists.txt b/src/testlib/CMakeLists.txt
index ed8d2c8df7..509748e51e 100644
--- a/src/testlib/CMakeLists.txt
+++ b/src/testlib/CMakeLists.txt
@@ -1,11 +1,11 @@
+# Generated from testlib.pro.
+
#####################################################################
## Test Module:
#####################################################################
add_qt_module(Test
- # Typically the Qt module name results in qt${module}-config.h, but
- # testlib is an exception where QtTest uses qttestlib-config.h.
- CONFIG_MODULE_NAME "testlib"
+ CONFIG_MODULE_NAME testlib # special case
SOURCES
qabstracttestlogger.cpp
qasciikey.cpp
@@ -48,42 +48,65 @@ add_qt_module(Test
qttestglobal.h
qxmltestlogger.cpp
qxunittestlogger.cpp
- LIBRARIES
- Qt::CorePrivate
- PUBLIC_LIBRARIES
- Qt::Core
DEFINES
+ QT_NO_CAST_TO_ASCII
QT_NO_CAST_FROM_ASCII
QT_NO_FOREACH
QT_NO_DATASTREAM
+ QT_BUILD_TESTLIB_LIB # special case
+ LIBRARIES
+ Qt::CorePrivate
+ PUBLIC_LIBRARIES # special case
+ Qt::Core
)
-# Typically the module name is also the define symbol, but testlib works
-# differently and uses QT_BUILD_TESTLIB_LIB, derived from the name testlib.pro.
-set_target_properties(Test PROPERTIES DEFINE_SYMBOL QT_BUILD_TESTLIB_LIB)
+#### Keys ignored in scope 1:.:testlib.pro:<NONE>:
+# CONFIG = "exceptions"
+# MODULE_CONFIG = "console" "testlib_defines"
+# _LOADED = "qt_module"
-### Platform support:
+## Scopes:
#####################################################################
-extend_target(Test CONDITION APPLE
+
+#### Keys ignored in scope 2:.:testlib.pro:UNIX AND NOT embedded:
+# QMAKE_PKGCONFIG_DESCRIPTION = "Qt" "Unit" "Testing" "Library"
+
+extend_target(Test CONDITION QT_FEATURE_itemmodeltester
SOURCES
- qappletestlogger.cpp qappletestlogger_p.h
- LIBRARIES ${FWSecurity}
+ qabstractitemmodeltester.cpp qabstractitemmodeltester.h
+)
- # FIXME: Skip XCTEST support, disabled in qmake build system
+extend_target(Test CONDITION embedded
+ COMPILE_OPTIONS
+ "-fno-rtti"
)
extend_target(Test CONDITION APPLE_OSX
- SOURCES qtestutil_macos.mm qtestutil_macos_p.h
- LIBRARIES ${FWFoundation} ${FWApplicationServices} ${FWIOKit}
+ SOURCES
+ qappletestlogger.cpp qappletestlogger_p.h
+ qtestutil_macos.mm qtestutil_macos_p.h
+ LIBRARIES
+ ${FWApplicationServices}
+ ${FWFoundation}
+ ${FWIOKit}
+ ${FWSecurity}
)
+# special case: Do not bother with disabld stuff:
+# extend_target(Test CONDITION (APPLE_OSX) AND (OFF AND NOT lessThan(QMAKE_XCODE_VERSION, "6.0")) ...
+# extend_target(Test CONDITION ((APPLE_OSX) AND (OFF AND NOT lessThan(QMAKE_XCODE_VERSION, "6.0"))) AND (NOT QMAKE_MAC_SDK_PLATFORM_PATH_ISEMPTY) ...
-### Feature support:
-#####################################################################
+#### Keys ignored in scope 8:.:testlib.pro:NOT QMAKE_MAC_SDK_PLATFORM_PATH_ISEMPTY:
+# MODULE_CONFIG = "xctest"
+# platform_dev_frameworks_path = "$${QMAKE_MAC_SDK_PLATFORM_PATH}/Developer/Library/Frameworks"
-## itemmodeltester:
-extend_target(Test CONDITION QT_FEATURE_itemmodeltester
- SOURCES qabstractitemmodeltester.cpp qabstractitemmodeltester.h
-)
+#### Keys ignored in scope 9:.:testlib.pro:NOT TARGET Qt::Gui:
+# HEADERSCLEAN_EXCLUDE = "qtest_gui.h" "qtestaccessible.h" "qtestkeyboard.h" "qtestmouse.h" "qtesttouch.h"
+
+#### Keys ignored in scope 10:.:testlib.pro:NOT TARGET Qt::Widgets:
+# HEADERSCLEAN_EXCLUDE = "qtest_widgets.h"
+
+#### Keys ignored in scope 11:.:testlib.pro:NOT TARGET Qt::Network:
+# HEADERSCLEAN_EXCLUDE = "qtest_network.h"
add_qt_docs(./doc/qttestlib.qdocconf)