summaryrefslogtreecommitdiffstats
path: root/src/testlib/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Hausmann <simon.hausmann@qt.io>2018-10-24 15:20:27 +0200
committerTobias Hunger <tobias.hunger@qt.io>2018-11-01 11:48:46 +0000
commite9c45bbdddd4df005bdaa5eea9740d351e6eaea2 (patch)
tree23765d4650f8f349d1f32e0fe4b1bc678cae7568 /src/testlib/CMakeLists.txt
parent345e6b0213b1273b698163064f80d33bc7ce64a9 (diff)
Begin port of qtbase to CMake
Done-by: Alexandru Croitor <alexandru.croitor@qt.io> Done-by: Frederik Gladhorn <frederik.gladhorn@qt.io> Done-by: Kevin Funk <kevin.funk@kdab.com> Done-by: Mikhail Svetkin <mikhail.svetkin@qt.io> Done-by: Simon Hausmann <simon.hausmann@qt.io> Done-by: Tobias Hunger <tobias.hunger@qt.io> Done-by: Tor Arne Vestbø <tor.arne.vestbo@qt.io> Done-by: Volker Krause <volker.krause@kdab.com> Change-Id: Ida4f8bd190f9a4849a1af7b5b7981337a5df5310 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io> Reviewed-by: Tobias Hunger <tobias.hunger@qt.io> Reviewed-by: Mikhail Svetkin <mikhail.svetkin@qt.io>
Diffstat (limited to 'src/testlib/CMakeLists.txt')
-rw-r--r--src/testlib/CMakeLists.txt89
1 files changed, 89 insertions, 0 deletions
diff --git a/src/testlib/CMakeLists.txt b/src/testlib/CMakeLists.txt
new file mode 100644
index 0000000000..3650fd0e37
--- /dev/null
+++ b/src/testlib/CMakeLists.txt
@@ -0,0 +1,89 @@
+#####################################################################
+## Test Module:
+#####################################################################
+
+add_qt_module(Test
+ # Typically the Qt module name results in qt${module}-config.h, but
+ # testlib is an exception where QtTest uses qttestlib-config.h.
+ CONFIG_MODULE_NAME "testlib"
+ SOURCES
+ qabstracttestlogger.cpp
+ qasciikey.cpp
+ qbenchmark.cpp qbenchmark.h qbenchmark_p.h
+ qbenchmarkevent.cpp qbenchmarkevent_p.h
+ qbenchmarkmeasurement.cpp qbenchmarkmeasurement_p.h
+ qbenchmarkmetric.cpp qbenchmarkmetric.h qbenchmarkmetric_p.h
+ qbenchmarkperfevents.cpp qbenchmarkperfevents_p.h
+ qbenchmarktimemeasurers_p.h
+ qbenchmarkvalgrind.cpp qbenchmarkvalgrind_p.h
+ qcsvbenchmarklogger.cpp
+ qplaintestlogger.cpp
+ qsignaldumper.cpp
+ qsignalspy.h
+ qtaptestlogger.cpp qtaptestlogger_p.h
+ qteamcitylogger.cpp
+ qtest.h
+ qtest_gui.h
+ qtest_network.h
+ qtest_widgets.h
+ qtestaccessible.h
+ qtestassert.h
+ qtestblacklist.cpp qtestblacklist_p.h
+ qtestcase.cpp qtestcase.h
+ qtestdata.cpp qtestdata.h
+ qtestelement.cpp
+ qtestelementattribute.cpp
+ qtestevent.h
+ qtesteventloop.h
+ qtesthelpers_p.h
+ qtestkeyboard.h
+ qtestlog.cpp
+ qtestmouse.cpp qtestmouse.h
+ qtestresult.cpp
+ qtestspontaneevent.h
+ qtestsystem.h
+ qtesttable.cpp
+ qtesttouch.h
+ qtestxunitstreamer.cpp
+ qttestglobal.h
+ qxmltestlogger.cpp
+ qxunittestlogger.cpp
+ LIBRARIES
+ CorePrivate
+ PUBLIC_LIBRARIES
+ Core
+ DEFINES
+ QT_NO_CAST_TO_ASCII QT_NO_CAST_FROM_ASCII
+ QT_NO_FOREACH
+ QT_NO_DATASTREAM
+)
+
+# Typically the module name is also the define symbol, but testlib works
+# differently and uses QT_BUILD_TESTLIB_LIB, derived from the name testlib.pro.
+set_target_properties(Test PROPERTIES DEFINE_SYMBOL QT_BUILD_TESTLIB_LIB)
+
+### Platform support:
+#####################################################################
+extend_target(Test CONDITION APPLE
+ SOURCES
+ qappletestlogger.cpp qappletestlogger_p.h
+ LIBRARIES ${FWSecurity}
+
+ # FIXME: Skip XCTEST support, disabled in qmake build system
+)
+
+extend_target(Test CONDITION APPLE_OSX
+ SOURCES qtestutil_macos.mm qtestutil_macos_p.h
+ LIBRARIES ${FWFoundation} ${FWApplicationServices} ${FWIOKit}
+)
+
+
+### Feature support:
+#####################################################################
+
+## itemmodeltester:
+extend_target(Test CONDITION QT_FEATURE_itemmodeltester
+ SOURCES qabstractitemmodeltester.cpp qabstractitemmodeltester.h
+)
+
+add_qt_docs(./doc/qttestlib.qdocconf)