summaryrefslogtreecommitdiffstats
path: root/src/tools/bootstrap/CMakeLists.txt
diff options
context:
space:
mode:
authorKevin Funk <kevin.funk@kdab.com>2019-02-12 10:22:09 +0100
committerKevin Funk <kevin.funk@kdab.com>2019-02-12 11:08:47 +0000
commit61b5a32df3192c5ea44944e2002665af2e51dc21 (patch)
tree9a66f6dc5db44fa7b8dc43169b5f91abcd6c04f2 /src/tools/bootstrap/CMakeLists.txt
parentb3560a66ae731599906a70bff19e38face2d9482 (diff)
cmake: Use consistent naming scheme for Bootstrap
Required for a future patch Change-Id: I63f85e8fb41ae7c76cb39cce00e63d4cc77aef9d Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'src/tools/bootstrap/CMakeLists.txt')
-rw-r--r--src/tools/bootstrap/CMakeLists.txt21
1 files changed, 11 insertions, 10 deletions
diff --git a/src/tools/bootstrap/CMakeLists.txt b/src/tools/bootstrap/CMakeLists.txt
index e85f7e9e16..d5d8bcd893 100644
--- a/src/tools/bootstrap/CMakeLists.txt
+++ b/src/tools/bootstrap/CMakeLists.txt
@@ -34,7 +34,7 @@ else()
set(os_libs "")
endif()
-add_library(QtBootstrap STATIC
+add_library(Bootstrap STATIC
../../corelib/codecs/qlatincodec.cpp
../../corelib/codecs/qtextcodec.cpp
../../corelib/codecs/qutfcodec.cpp
@@ -113,18 +113,19 @@ add_library(QtBootstrap STATIC
${os_sources}
)
-add_library(Qt::Bootstrap ALIAS QtBootstrap)
+add_library(Qt::Bootstrap ALIAS Bootstrap)
+qt_internal_add_target_aliases(Bootstrap)
qt_ensure_perl()
foreach(module QtCore QtXml)
execute_process(COMMAND "${HOST_PERL}" -w "${PROJECT_SOURCE_DIR}/bin/syncqt.pl" -quiet -minimal -module "${module}" -version "${PROJECT_VERSION}" -outdir "${PROJECT_BINARY_DIR}" "${PROJECT_SOURCE_DIR}")
- target_include_directories(QtBootstrap PUBLIC
+ target_include_directories(Bootstrap PUBLIC
"${PROJECT_BINARY_DIR}/include/${module}"
"${PROJECT_BINARY_DIR}/include/${module}/${PROJECT_VERSION}"
"${PROJECT_BINARY_DIR}/include/${module}/${PROJECT_VERSION}/${module}")
endforeach()
-target_compile_definitions(QtBootstrap PUBLIC
+target_compile_definitions(Bootstrap PUBLIC
QT_VERSION_MAJOR=${PROJECT_VERSION_MAJOR}
QT_VERSION_MINOR=${PROJECT_VERSION_MINOR}
QT_VERSION_PATCH=${PROJECT_VERSION_PATCH}
@@ -134,18 +135,18 @@ target_compile_definitions(QtBootstrap PUBLIC
QT_NO_FOREACH
QT_NO_CAST_FROM_ASCII
)
-target_link_libraries(QtBootstrap PUBLIC Qt::Platform ${os_libs})
-target_include_directories(QtBootstrap PUBLIC "${PROJECT_BINARY_DIR}/include")
-target_link_libraries(QtBootstrap PRIVATE ZLIB::ZLIB)
+target_link_libraries(Bootstrap PUBLIC Qt::Platform ${os_libs})
+target_include_directories(Bootstrap PUBLIC "${PROJECT_BINARY_DIR}/include")
+target_link_libraries(Bootstrap PRIVATE ZLIB::ZLIB)
### fixme: Expose as some cmake equivalent of a reusable qmake mkspecs/features/gc_binaries.prf.
if(APPLE)
- target_link_libraries(QtBootstrap INTERFACE "-Wl,-dead_strip")
+ target_link_libraries(Bootstrap INTERFACE "-Wl,-dead_strip")
endif()
if (APPLE)
find_library(FWFoundation Foundation)
find_library(FWCoreServices CoreServices)
- target_link_libraries(QtBootstrap INTERFACE ${FWFoundation})
- target_link_libraries(QtBootstrap PRIVATE ${FWCoreServices})
+ target_link_libraries(Bootstrap INTERFACE ${FWFoundation})
+ target_link_libraries(Bootstrap PRIVATE ${FWCoreServices})
endif()