summaryrefslogtreecommitdiffstats
path: root/src/tools/bootstrap/CMakeLists.txt
diff options
context:
space:
mode:
authorLars Knoll <lars.knoll@qt.io>2020-05-19 17:28:42 +0200
committerKarsten Heimrich <karsten.heimrich@qt.io>2020-08-19 19:48:09 +0200
commit6eb1cdd1c6dc8cabc392942d0e1a1e1e89b6cc61 (patch)
tree3eeb22ae7a01f9648191aebc83d0a6cc053c8db2 /src/tools/bootstrap/CMakeLists.txt
parent2fa660f43654ccfda3f9dba80b18c34c3b52399f (diff)
Refactor qxmlstream_p.h
Pull the file apart, so that the parts generated from qxmlstream.g are separated from the definition of the private class. This will in the future simplify maintenance and refactoring. Change-Id: I4a9c1bb1e377dee1e6d3b9aa9b0dfa64c5806c45 Reviewed-by: Alex Blasche <alexander.blasche@qt.io>
Diffstat (limited to 'src/tools/bootstrap/CMakeLists.txt')
-rw-r--r--src/tools/bootstrap/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/tools/bootstrap/CMakeLists.txt b/src/tools/bootstrap/CMakeLists.txt
index 3510c130cc..56b1bcbbcf 100644
--- a/src/tools/bootstrap/CMakeLists.txt
+++ b/src/tools/bootstrap/CMakeLists.txt
@@ -95,6 +95,7 @@ qt_extend_target(Bootstrap
../../corelib/serialization/qjsonwriter.cpp
../../corelib/serialization/qtextstream.cpp
../../corelib/serialization/qxmlstream.cpp
+ ../../corelib/serialization/qxmlstreamgrammar.cpp
../../corelib/serialization/qxmlutils.cpp
../../corelib/text/qbytearray.cpp
../../corelib/text/qbytearraylist.cpp