summaryrefslogtreecommitdiffstats
path: root/src/tools/qdbuscpp2xml/CMakeLists.txt
diff options
context:
space:
mode:
authorLeander Beernaert <leander.beernaert@qt.io>2020-04-27 15:04:57 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2020-06-02 22:42:15 +0200
commit5a779a4ad350accadc4337d332eedb29ba1cc26b (patch)
tree50263a99b188539a28aaf733a07bb0072eab8fa8 /src/tools/qdbuscpp2xml/CMakeLists.txt
parent47c6466d0acc6d8d733b4fdbaf980a60bbfc93ef (diff)
CMake: Make it possible to build tools when cross-compiling
This patch allows tools to be built for the target platform when the QT_BUILD_TOOLS_WHEN_CROSSCOMPILING parameter is set at configuration time. To avoid naming conflicts, the target tools are suffixed with "_native". The qt_get_tool_target_name() function can be used to get the tool name for both scenarios (cross and non-cross compilation). Extend pro2cmake to refer to the right target name for tools. The relevant write_XXX functions have a new target_ref parameter that will be "${target_name}" for tools and literally the target name for everything else. Fixes: QTBUG-81901 Change-Id: If4efbc1fae07a4a3a044dd09c9c06be6d517825e Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/tools/qdbuscpp2xml/CMakeLists.txt')
-rw-r--r--src/tools/qdbuscpp2xml/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/tools/qdbuscpp2xml/CMakeLists.txt b/src/tools/qdbuscpp2xml/CMakeLists.txt
index de4f0f59bb..e831d5f392 100644
--- a/src/tools/qdbuscpp2xml/CMakeLists.txt
+++ b/src/tools/qdbuscpp2xml/CMakeLists.txt
@@ -4,7 +4,8 @@
## qdbuscpp2xml Tool:
#####################################################################
-qt_add_tool(qdbuscpp2xml
+qt_get_tool_target_name(target_name qdbuscpp2xml)
+qt_add_tool(${target_name}
TARGET_DESCRIPTION "Qt D-Bus C++ to XML Compiler"
TOOLS_TARGET DBus # special case
SOURCES
@@ -46,4 +47,3 @@ qt_add_tool(qdbuscpp2xml
# extend_target(qdbuscpp2xml CONDITION force_bootstrap [...])
# extend_target(qdbuscpp2xml CONDITION NOT force_bootstrap [...])
# special case end
-