summaryrefslogtreecommitdiffstats
path: root/src/widgets/CMakeLists.txt
diff options
context:
space:
mode:
authorMitch Curtis <mitch.curtis@qt.io>2020-03-10 15:40:56 +0100
committerVolker Hilsheimer <volker.hilsheimer@qt.io>2020-03-30 12:36:29 +0200
commit3f73995a03c4b40e2648cb9af5d3e7ca393bf597 (patch)
treef7f9f4c63a5506287de4d44d4f01cdc57e093a27 /src/widgets/CMakeLists.txt
parentadc1be3c33b4237a13e423c140bcb1c06aeb11d9 (diff)
Move undo framework out of Qt Widgets
- Moves QUndo* classes (except QUndoView) from src/widgets/utils to src/gui/utils - Moves related auto tests from widgets to gui - Replaces QUndoAction with lambdas that do text prefixing [ChangeLog][Undo Framework] QUndo* classes (except QUndoView) were moved from Qt Widgets to Qt GUI. Done-with: volker.hilsheimer@qt.io Fixes: QTBUG-40040 Change-Id: I3bd8d4d32c64f8dee548f62159a1df2126da89d8 Reviewed-by: Lars Knoll <lars.knoll@qt.io> Reviewed-by: Volker Hilsheimer <volker.hilsheimer@qt.io>
Diffstat (limited to 'src/widgets/CMakeLists.txt')
-rw-r--r--src/widgets/CMakeLists.txt10
1 files changed, 0 insertions, 10 deletions
diff --git a/src/widgets/CMakeLists.txt b/src/widgets/CMakeLists.txt
index 9730b787be..8b2f599a60 100644
--- a/src/widgets/CMakeLists.txt
+++ b/src/widgets/CMakeLists.txt
@@ -796,16 +796,6 @@ qt_extend_target(Widgets CONDITION QT_FEATURE_scroller
util/qscrollerproperties.cpp util/qscrollerproperties.h util/qscrollerproperties_p.h
)
-qt_extend_target(Widgets CONDITION QT_FEATURE_undocommand
- SOURCES
- util/qundostack.cpp util/qundostack.h util/qundostack_p.h
-)
-
-qt_extend_target(Widgets CONDITION QT_FEATURE_undogroup
- SOURCES
- util/qundogroup.cpp util/qundogroup.h
-)
-
qt_extend_target(Widgets CONDITION QT_FEATURE_undoview
SOURCES
util/qundoview.cpp util/qundoview.h