summaryrefslogtreecommitdiffstats
path: root/src/widgets/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Hausmann <simon.hausmann@qt.io>2019-10-17 10:02:48 +0200
committerSimon Hausmann <simon.hausmann@qt.io>2019-10-17 16:56:23 +0000
commit4df389eb4f1ae10284c03023e923ce2164d46753 (patch)
tree0bf380793f86b06cc92c3dcb12d858e199c7cd7d /src/widgets/CMakeLists.txt
parent02164e0288f714f1ea93afb32548548686773d1d (diff)
Re-generate affected cmake files and configure.json after the merge
This also removes the workarounds of commit b2662b05dd078c46b82f5f041f51b0b83554113d now that it's fixed "upstream" in the .pro files. Change-Id: Idd5e6273873a700fcda5a6cad2039c4e88b61f6f Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'src/widgets/CMakeLists.txt')
-rw-r--r--src/widgets/CMakeLists.txt29
1 files changed, 15 insertions, 14 deletions
diff --git a/src/widgets/CMakeLists.txt b/src/widgets/CMakeLists.txt
index 4ca3a70241..4fb69ee475 100644
--- a/src/widgets/CMakeLists.txt
+++ b/src/widgets/CMakeLists.txt
@@ -651,20 +651,21 @@ extend_target(Widgets CONDITION QT_FEATURE_messagebox
dialogs/qmessagebox.cpp dialogs/qmessagebox.h
)
-# Resources:
-set(qmessagebox_resource_files
- "images/qtlogo-64.png"
-)
-
-add_qt_resource(Widgets "qmessagebox"
- PREFIX
- "/qt-project.org/qmessagebox"
- BASE
- "dialogs"
- FILES
- ${qmessagebox_resource_files}
-)
-
+if(QT_FEATURE_messagebox)
+ # Resources:
+ set(qmessagebox_resource_files
+ "images/qtlogo-64.png"
+ )
+
+ add_qt_resource(Widgets "qmessagebox"
+ PREFIX
+ "/qt-project.org/qmessagebox"
+ BASE
+ "dialogs"
+ FILES
+ ${qmessagebox_resource_files}
+ )
+endif()
extend_target(Widgets CONDITION QT_FEATURE_progressdialog
SOURCES