summaryrefslogtreecommitdiffstats
path: root/src/widgets/CMakeLists.txt
diff options
context:
space:
mode:
authorAhmad Samir <a.samirh78@gmail.com>2023-08-11 01:33:49 +0300
committerAhmad Samir <a.samirh78@gmail.com>2023-10-13 00:54:54 +0300
commit8ce54407f27c209ad48d6ae3b15ad3230ffd0b93 (patch)
treedfb96fe0e64a54e8e306ecc5cb024d07847fffc6 /src/widgets/CMakeLists.txt
parent2309b38a64b67b0f5deaa1e80d8f07df38ba0795 (diff)
QGestureManager: port Q_FOREACH to ranged-for [6/6]
These two QSetS are local to the function, the loop bodies don't modify them but they can't be made const due to the way they're filled. So use std::as_const and ranged-for. Un-blacklist the file, by removing "#undef QT_NO_FOREACH", and removing the source file from NO_PCH_SOURCES. Change-Id: I49b852aa865b0321d3e2f617466557d77143a32b Task-number: QTBUG-115803 Reviewed-by: Christian Ehrlicher <ch.ehrlicher@gmx.de> Reviewed-by: Marc Mutz <marc.mutz@qt.io>
Diffstat (limited to 'src/widgets/CMakeLists.txt')
-rw-r--r--src/widgets/CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/src/widgets/CMakeLists.txt b/src/widgets/CMakeLists.txt
index 8117ed9a31..9e21cfafd5 100644
--- a/src/widgets/CMakeLists.txt
+++ b/src/widgets/CMakeLists.txt
@@ -70,7 +70,6 @@ qt_internal_add_module(Widgets
"kernel/qt_widgets_pch.h"
NO_PCH_SOURCES
compat/removed_api.cpp
- kernel/qgesturemanager.cpp # undef QT_NO_FOREACH
GENERATE_CPP_EXPORTS
)