summaryrefslogtreecommitdiffstats
path: root/src/widgets/CMakeLists.txt
diff options
context:
space:
mode:
authorSimon Hausmann <simon.hausmann@qt.io>2019-05-29 16:56:49 +0200
committerSimon Hausmann <simon.hausmann@qt.io>2019-05-31 12:53:09 +0000
commit8fa646dbe2eba9674809042ff15e98f0eb1018d5 (patch)
treeb3f4e68c5d7d0fac7ec8a2f9514ad1a6790b2d25 /src/widgets/CMakeLists.txt
parentfc6d4af08d049909071a4eefdc91c26ac2e3df40 (diff)
Add basic support for compiling applications with qmake
* Generate module .pri files * Generate qconfig.pri * Propagate MODULE_CONFIG from the .pro files This enables the basic use-case of simple application builds that for example use the moc. Omitted from the patch is support for private module configurations, prl files (should we do this?) and possibly more hidden gems that need to be implemented to for example support building Qt modules with qmake. Task-number: QTBUG-75666 Change-Id: Icbf0d9ccea4cd683e4c38340b9a2320bf7951d0d Reviewed-by: Qt CMake Build Bot Reviewed-by: Tobias Hunger <tobias.hunger@qt.io>
Diffstat (limited to 'src/widgets/CMakeLists.txt')
-rw-r--r--src/widgets/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/widgets/CMakeLists.txt b/src/widgets/CMakeLists.txt
index d946bc8e1d..95ee3bed65 100644
--- a/src/widgets/CMakeLists.txt
+++ b/src/widgets/CMakeLists.txt
@@ -5,6 +5,7 @@
#####################################################################
add_qt_module(Widgets
+ QMAKE_MODULE_CONFIG uic
SOURCES
itemviews/qfileiconprovider.cpp itemviews/qfileiconprovider.h itemviews/qfileiconprovider_p.h
kernel/qaction.cpp kernel/qaction.h kernel/qaction_p.h