summaryrefslogtreecommitdiffstats
path: root/src/widgets/CMakeLists.txt
diff options
context:
space:
mode:
authorMarc Mutz <marc.mutz@qt.io>2023-08-04 23:04:53 +0200
committerMarc Mutz <marc.mutz@qt.io>2023-08-05 20:21:16 +0200
commita631fef20f0ad59cd85e2247731641ece2338c30 (patch)
tree296d5d7c9eea9ce606d4ba5aad04d2c509e96b4b /src/widgets/CMakeLists.txt
parent81685b0ac08e5ff454a6af9a8d98bd4a63b247dd (diff)
QtWidgets: use NO_PCH_SOURCES instead of manual no-pch handling
This is how all other libraries handle this, so use it here, too. Amends 0c8b98774cd0f3dad939d31e820e7e47c1da088a and 09d1196281ccd03dac55781ac91f6c4eb7bb4de9. Pick-to: 6.6 6.5 Change-Id: Id3b8fa1b834e2bebe5e6ddc1f67e43c66ccd9aab Reviewed-by: Alexey Edelev <alexey.edelev@qt.io>
Diffstat (limited to 'src/widgets/CMakeLists.txt')
-rw-r--r--src/widgets/CMakeLists.txt11
1 files changed, 2 insertions, 9 deletions
diff --git a/src/widgets/CMakeLists.txt b/src/widgets/CMakeLists.txt
index 9a508cc14e..2a4eb5389c 100644
--- a/src/widgets/CMakeLists.txt
+++ b/src/widgets/CMakeLists.txt
@@ -66,6 +66,8 @@ qt_internal_add_module(Widgets
Qt::GuiPrivate
PRECOMPILED_HEADER
"kernel/qt_widgets_pch.h"
+ NO_PCH_SOURCES
+ compat/removed_api.cpp
GENERATE_CPP_EXPORTS
)
@@ -245,15 +247,6 @@ set(qstyle_resource_files
"styles/images/viewlist-32.png"
)
-set(widgets_no_pch_sources
- compat/removed_api.cpp
-)
-
-foreach(src ${widgets_no_pch_sources})
- qt_update_ignore_pch_source(Widgets ${src})
-endforeach()
-
-
qt_internal_add_resource(Widgets "qstyle"
PREFIX
"/qt-project.org/styles/commonstyle"