summaryrefslogtreecommitdiffstats
path: root/src/widgets/CMakeLists.txt
diff options
context:
space:
mode:
authorVolker Hilsheimer <volker.hilsheimer@qt.io>2020-03-19 16:45:15 +0100
committerVolker Hilsheimer <volker.hilsheimer@qt.io>2020-03-29 19:31:14 +0100
commitd975ad4ed728553b765c61f38c1e0df899187cf5 (patch)
treecab1916d88fb6472e051b6b81f97aa3a23407c37 /src/widgets/CMakeLists.txt
parentbcaff2b06fc46fce8a3ae6d613c025c8d097229c (diff)
Merge QGuiShortcut and QShortcut again in QtGui
QShortcut has only one widget specific feature, which is whatsThis; that is just a QString, so the setters and getters can just as well be in QtGui. The widgets specific implementation of shortcut matching and of showing the whatsThis balloon stays in QtWidgets, in the private implementation. Using virtual functions in the private we can override the empty default in QtGui, and by adding a virtual factory function in QGuiApplication, the correct private is instantiated depending on the kind of application running. Change-Id: I09ae4a5482f9fb70940c5e2bfe76d3d7fd710afc Reviewed-by: Lars Knoll <lars.knoll@qt.io>
Diffstat (limited to 'src/widgets/CMakeLists.txt')
-rw-r--r--src/widgets/CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/src/widgets/CMakeLists.txt b/src/widgets/CMakeLists.txt
index 8fa3090475..9730b787be 100644
--- a/src/widgets/CMakeLists.txt
+++ b/src/widgets/CMakeLists.txt
@@ -334,7 +334,7 @@ qt_extend_target(Widgets CONDITION QT_FEATURE_formlayout
qt_extend_target(Widgets CONDITION QT_FEATURE_shortcut
SOURCES
- kernel/qshortcut.cpp kernel/qshortcut.h
+ kernel/qshortcut_widgets.cpp
)
qt_extend_target(Widgets CONDITION QT_FEATURE_tooltip