summaryrefslogtreecommitdiffstats
path: root/src/winmain/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2020-09-22 10:16:58 +0200
committerAlexandru Croitor <alexandru.croitor@qt.io>2020-09-23 16:59:06 +0200
commit403213240c7b2dc09378e1cb8c147131e368f90c (patch)
treeff86910332629fe5e2fab59a30fb863a5febb366 /src/winmain/CMakeLists.txt
parente0c62a48b8a826a46a143e57e94b2a0ea73c7cae (diff)
CMake: Regenerate projects to use new qt_internal_ API
Modify special case locations to use the new API as well. Clean up some stale .prev files that are not needed anymore. Clean up some project files that are not used anymore. Task-number: QTBUG-86815 Change-Id: I9947da921f98686023c6bb053dfcc101851276b5 Reviewed-by: Joerg Bornemann <joerg.bornemann@qt.io> Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org>
Diffstat (limited to 'src/winmain/CMakeLists.txt')
-rw-r--r--src/winmain/CMakeLists.txt6
1 files changed, 3 insertions, 3 deletions
diff --git a/src/winmain/CMakeLists.txt b/src/winmain/CMakeLists.txt
index fca2609082..1a74a1e3ae 100644
--- a/src/winmain/CMakeLists.txt
+++ b/src/winmain/CMakeLists.txt
@@ -4,7 +4,7 @@ if (NOT WIN32)
return()
endif()
-qt_add_module(WinMain
+qt_internal_add_module(WinMain
STATIC
NO_SYNC_QT
NO_MODULE_HEADERS
@@ -22,12 +22,12 @@ endif()
set_property(TARGET WinMain PROPERTY OUTPUT_NAME qtmain)
-qt_extend_target(WinMain CONDITION
+qt_internal_extend_target(WinMain CONDITION
SOURCES qtmain_win.cpp
LIBRARIES shell32
)
-qt_extend_target(WinMain CONDITION MINGW
+qt_internal_extend_target(WinMain CONDITION MINGW
DEFINES QT_NEEDS_QMAIN
)
# special case end