summaryrefslogtreecommitdiffstats
path: root/tests/auto/CMakeLists.txt
diff options
context:
space:
mode:
authorEven Oscar Andersen <even.oscar.andersen@qt.io>2024-02-22 09:52:27 +0100
committerEven Oscar Andersen <even.oscar.andersen@qt.io>2024-04-13 11:32:17 +0100
commitc0fdd4b4513a2cbf805ee05a29b31ecab1aa89bb (patch)
tree13239f91609428f1f13671df15750df955b75787 /tests/auto/CMakeLists.txt
parent3e049f06557d0e3483b7fa40ecf8c9a918d8ac3a (diff)
wasm: Add auto test for qfile
Problems: * mmap of size 0 works, add test in QFSFileEnginePrivate::map to make sure wasm platform behaves as the other platforms * qwe// is a valid filename on wasm, QSKIP test * applicationFilePath does not exist on wasm. * /dev/zero does not exist on wasm, file bug, skip test * blocking pipes do not exist on wasm, QSKIP test * socketpair does not exist on wasm, QSKIP test Change-Id: I1705c543782cbcb92a7ebed2fc2792613524c686 Reviewed-by: Morten Johan Sørvig <morten.sorvig@qt.io>
Diffstat (limited to 'tests/auto/CMakeLists.txt')
-rw-r--r--tests/auto/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/auto/CMakeLists.txt b/tests/auto/CMakeLists.txt
index 06e9b9ac6c..74e7b2c5dd 100644
--- a/tests/auto/CMakeLists.txt
+++ b/tests/auto/CMakeLists.txt
@@ -63,6 +63,7 @@ if(WASM)
add_subdirectory(corelib/io/qbuffer)
add_subdirectory(corelib/io/qabstractfileengine)
add_subdirectory(corelib/io/qsettings)
+ add_subdirectory(corelib/io/qfile)
add_subdirectory(corelib/serialization)
add_subdirectory(corelib/text)
add_subdirectory(corelib/thread)