summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorJiDe Zhang <zhangjide@uniontech.com>2021-01-16 04:27:39 +0800
committerAlexey Edelev <alexey.edelev@qt.io>2021-04-23 18:51:30 +0200
commit22e967c3049608f82abd32a0beb0b4b36ee134bf (patch)
treebb92fc22698ba34b596728214580e193e7068ecf /tests/auto/cmake/CMakeLists.txt
parentf1c37ead59cff4ce5788c75a9183f327c0681480 (diff)
fix: The QtStartUpFunction function may be called repeatedly
Don't call pre routine function in qAddPreRoutine if the qt_call_pre_routines is not called Pick-to: 6.1 6.0 Task-number: QTBUG-90341 Change-Id: I0ee70561dc57b857f8b3b1cf42c9dfe0cf45bd49 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/cmake/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/auto/cmake/CMakeLists.txt b/tests/auto/cmake/CMakeLists.txt
index 1a5bc1f36c..9311911a09 100644
--- a/tests/auto/cmake/CMakeLists.txt
+++ b/tests/auto/cmake/CMakeLists.txt
@@ -215,3 +215,5 @@ _qt_internal_test_expect_pass(test_add_resources_binary_generated
include(test_plugin_shared_static_flavor.cmake)
_qt_internal_test_expect_pass(test_init_resources_static_plugin
BINARY test_init_resources_static_plugin)
+_qt_internal_test_expect_pass(tst_qaddpreroutine
+ BINARY tst_qaddpreroutine)