summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2021-11-24 16:22:18 +0100
committerAlexey Edelev <alexey.edelev@qt.io>2021-12-02 16:34:23 +0100
commit63b8840380e70c1258f56c67a2ec5edb5bdea53d (patch)
tree465fedceda0553c0beec5e5e0f46cd03d1d97abf /tests/auto/cmake/CMakeLists.txt
parent7a6dd6084cb6dc3d8ad0476d9630ad7c575bca19 (diff)
Fix dependency chain that collects the metatype json files
cmake_automoc_parser has the logic preventing the run of moc with the --collect-json parameter if metatype json files are not changed. This logic only verify if the file list is changed but not their content. This change adds a timestamp file that contains the last metatype json file timestamp that was modified during the last cmake_automoc_parser run. The logic still prevents of running 'moc --collect-json' when the list of metatype json files is not changed, but also checks if their content is no changed. Another approach it to generate the depfile that can be utilized by CMake in add_custom_command as DEPFILE argument. But this concept only works from the second build attempt because of an issue related to dyndep. Pick-to: 6.2 Fixes: QTBUG-98532 Change-Id: I713f8bfa9ae769cefe0beac0b7fa19750b00a765 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/cmake/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/auto/cmake/CMakeLists.txt b/tests/auto/cmake/CMakeLists.txt
index dfbbb19828..8073a47c16 100644
--- a/tests/auto/cmake/CMakeLists.txt
+++ b/tests/auto/cmake/CMakeLists.txt
@@ -282,3 +282,5 @@ _qt_internal_test_expect_pass(test_static_resources
BINARY_ARGS "-V")
_qt_internal_test_expect_pass(test_generating_cpp_exports)
+
+_qt_internal_test_expect_pass(test_qt_extract_metatypes)