summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2024-02-05 17:37:45 +0100
committerAlexey Edelev <alexey.edelev@qt.io>2024-02-06 20:23:18 +0100
commit75d83d5a6521a5cf5c7159f1ef09e8978e429919 (patch)
tree0f9ad3a713c4a12706a47a82d67afa79e5cc1c34 /tests/auto/cmake/CMakeLists.txt
parentcdfeca26cf313b84f6a9b1380e039f214357c52f (diff)
Add plugins of imported QtModules to the _qt_plugins property
This covers the following use case: QtModuleX is pre-built and installed, it's imported. The plugin has a PLUGIN_TYPE that is associated with QtModuleX and is built with application that links QtModuleX. When deploying the application it's expected that the plugin is deployed, as the one that belongs to the linked QtModuleX. This ensures that we udpate the internal _qt_plugins property that is used in the __qt_internal_collect_plugin_targets_from_dependencies function. Pick-to: 6.5 6.6 6.7 Change-Id: I9824351ebab5a24509800da4db69f1e282a35884 Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/cmake/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/auto/cmake/CMakeLists.txt b/tests/auto/cmake/CMakeLists.txt
index f71468cee8..7152f820f5 100644
--- a/tests/auto/cmake/CMakeLists.txt
+++ b/tests/auto/cmake/CMakeLists.txt
@@ -393,3 +393,6 @@ endif()
_qt_internal_test_expect_pass(test_config_expressions)
_qt_internal_test_expect_pass(test_QTP0003)
+if(NOT NO_GUI)
+ _qt_internal_test_expect_pass(test_collecting_plugins)
+endif()