summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexandru Croitor <alexandru.croitor@qt.io>2022-11-01 18:16:34 +0100
committerAlexandru Croitor <alexandru.croitor@qt.io>2022-12-02 20:53:01 +0100
commit9b2c82cc8424f65a00ec6d5842103181e27604ee (patch)
treec6661d42fd579a71cee3792de1beb21a473fef28 /tests/auto/cmake/CMakeLists.txt
parent919664b29a874e8cdc3d74427654cbaa2b61be29 (diff)
CMake: Add auto test for qt_add_resources dependency rebuilding
Make sure that touching any file that is part of a qrc resource actually rebuilds the resource and the target that depends on the resource. Pick-to: 6.4 Task-number: QTBUG-107687 Task-number: QTBUG-108113 Change-Id: I1153dc13fee44ffe59d2685a8cb33303538b026c Reviewed-by: Alexey Edelev <alexey.edelev@qt.io>
Diffstat (limited to 'tests/auto/cmake/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/auto/cmake/CMakeLists.txt b/tests/auto/cmake/CMakeLists.txt
index 99d36c3d56..61cd6d588e 100644
--- a/tests/auto/cmake/CMakeLists.txt
+++ b/tests/auto/cmake/CMakeLists.txt
@@ -185,6 +185,7 @@ endif()
_qt_internal_test_expect_pass(test_multiple_find_package)
_qt_internal_test_expect_pass(test_add_resources_delayed_file)
_qt_internal_test_expect_pass(test_add_binary_resources_delayed_file BINARY test_add_binary_resources_delayed_file)
+_qt_internal_test_expect_pass(test_qt_add_resources_rebuild)
if(NOT NO_GUI)
_qt_internal_test_expect_pass(test_private_includes)