summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2021-06-22 17:37:55 +0200
committerAlexey Edelev <alexey.edelev@qt.io>2021-06-24 20:40:49 +0200
commit9bd418aeab6a3d1b814023c35b869a3fc529cbb2 (patch)
tree41b7cab935127dd70e2733c31e715bb4cd6ab512 /tests/auto/cmake/CMakeLists.txt
parent4b850065b1631437b65542b3cb1c16077d2f0230 (diff)
Implement generating of a module cpp export header
Add an option that automatically generates an export header for a Qt module. The header contains only Q_DECL_EXPORT/Q_DECL_IMPORT related content, so it's not a full replacement of 'global' header files. Task-number: QTBUG-90492 Change-Id: I250d1201b11d4096b7e78e61cbf4565945fe6517 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/cmake/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/auto/cmake/CMakeLists.txt b/tests/auto/cmake/CMakeLists.txt
index 8852c7e68b..c2ab33c96b 100644
--- a/tests/auto/cmake/CMakeLists.txt
+++ b/tests/auto/cmake/CMakeLists.txt
@@ -261,3 +261,5 @@ _qt_internal_test_expect_pass(tst_qaddpreroutine
_qt_internal_test_expect_pass(test_static_resources
BINARY "${CMAKE_CTEST_COMMAND}"
BINARY_ARGS "-V")
+
+_qt_internal_test_expect_pass(test_generating_cpp_exports)