summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2022-08-16 10:42:48 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2022-09-15 12:55:23 +0200
commitc9c04291f5f96ff885f7caae6c15ce9bc1377fcc (patch)
treebc2fc9d726915445181a2db48ec7089930b0b488 /tests/auto/cmake/CMakeLists.txt
parent6329fed0a8721a530d9dc485ecc5611a22db59d9 (diff)
CMake: Add Linux support to qt_deploy_runtime_dependencies
Before this change, qt_deploy_runtime_dependencies supported Windows and macOS only. We add a generic deployment method implemented in cmake-language with file(GET_RUNTIME_DEPENDENCIES). This deployment method is now enabled for shared builds on Linux. The file(GRD) command requires that the EXECUTABLE argument points to the executable in the build directory. Only libraries in Qt's installation directory are considered for deployment. This includes Qt's own libraries and also things like libicu*.so we're shipping with the installer. Unlike macdeployqt and windeployqt, the generic qt_deploy_runtime_dependencies does not yet support deploying translations. We will catch up on this in a later commit. Change-Id: Iea23abcdba774d4c1885c8d2c243eb3e48fb7fae Reviewed-by: Qt CI Bot <qt_ci_bot@qt-project.org> Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/cmake/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/auto/cmake/CMakeLists.txt b/tests/auto/cmake/CMakeLists.txt
index eaf4fe67f0..5153350eb6 100644
--- a/tests/auto/cmake/CMakeLists.txt
+++ b/tests/auto/cmake/CMakeLists.txt
@@ -328,7 +328,8 @@ set(deploy_args
# other platforms, because there is no support for runtime dependency deployment
# on those platforms.
# With static builds the runtime dependencies are just skipped, but the test should still pass.
-if((WIN32 OR (APPLE AND NOT IOS)))
+if(WIN32 OR (APPLE AND NOT IOS)
+ OR (UNIX AND NOT APPLE AND NOT ANDROID AND NOT CMAKE_CROSSCOMPILING))
_qt_internal_test_expect_pass(${deploy_args})
else()
_qt_internal_test_expect_fail(${deploy_args})