summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorAmir Masoud Abdol <amirmasoudabdol@icloud.com>2022-10-17 15:50:18 +0200
committerAmir Masoud Abdol <amir.abdol@qt.io>2022-12-05 18:02:59 +0000
commitd77ce33082516234fd7bbb5335401a1f3af8ca27 (patch)
treeb0d3247a9c14763d857adeba58d88a5f97152314 /tests/auto/cmake/CMakeLists.txt
parent3b0ef746942d9c0d44d418020849cecfa480a19d (diff)
Move Some of the Private CMake Helper Scripts from `bin/` to `libexec/`
After this change, private CMake scripts are mostly live in `libexec/`, except the `qt-cmake` which will stay in `bin/`. This doesn't affect the Windows configuration. - `qt-cmake` stays in `bin/` - `qt-configure-module` moves into `libexec/` - `qt-cmake-private` moves into `libexec/` - `qt-cmake-private-install.cmake` moves into `libexec/` - `qt-cmake-standalone-test` moves into `libexec/` - `qt-internal-configure-test` moves into `libexec/` In cases where `QT_GENERATE_WRAPPER_SCRIPTS_FOR_ALL_HOSTS` is set to ON, e.g., ANDROID, WASM, both Batch and Bash files will be generated and placed in `bin/` and `libexec/` accordingly; in both cases, qt-cmake and qt-cmake.bat will be in `bin/` anyway. [ChangeLog][CMake] The private Qt CMake scripts, i.e., qt-configure-module, qt-cmake-private, qt-cmake-private-install.cmake, qt-cmake-standalone-test and qt-internal-configure-test were moved into $prefix/libexec on Unix platforms. Fixes: QTBUG-107621 Change-Id: Ic4f4ec85f64d2ede0e208bca928959e30be906a6 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/cmake/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/CMakeLists.txt11
1 files changed, 6 insertions, 5 deletions
diff --git a/tests/auto/cmake/CMakeLists.txt b/tests/auto/cmake/CMakeLists.txt
index 61cd6d588e..42cbc03138 100644
--- a/tests/auto/cmake/CMakeLists.txt
+++ b/tests/auto/cmake/CMakeLists.txt
@@ -275,10 +275,11 @@ if(QT_BUILD_INTERNALS_RELOCATABLE_INSTALL_PREFIX)
elseif(QT6_INSTALL_PREFIX)
set(qt_install_prefix "${QT6_INSTALL_PREFIX}")
endif()
-if(INSTALL_BINDIR)
- set(qt_install_bin_dir "${INSTALL_BINDIR}")
-elseif(QT6_INSTALL_BINS)
- set(qt_install_bin_dir "${QT6_INSTALL_BINS}")
+
+if(INSTALL_LIBEXECDIR)
+ set(qt_install_libexec_dir "${INSTALL_LIBEXECDIR}")
+elseif(QT6_INSTALL_LIBEXECS)
+ set(qt_install_libexec_dir "${QT6_INSTALL_LIBEXECS}")
endif()
# Test building and installing a few dummy Qt modules and plugins.
@@ -289,7 +290,7 @@ if(is_qt_build_platform)
BINARY "${CMAKE_COMMAND}"
BINARY_ARGS
"-DQT_BUILD_DIR=${CMAKE_CURRENT_BINARY_DIR}/mockplugins"
- -P "${qt_install_prefix}/${qt_install_bin_dir}/qt-cmake-private-install.cmake"
+ -P "${qt_install_prefix}/${qt_install_libexec_dir}/qt-cmake-private-install.cmake"
)
endif()
_qt_internal_test_expect_pass(mockplugins ${mockplugins_test_args})