summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/mockplugins/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Edelev <alexey.edelev@qt.io>2023-04-12 15:04:14 +0200
committerAlexey Edelev <alexey.edelev@qt.io>2023-04-24 14:20:25 +0200
commitf3c10280f59d35fbf0862e6e353602e7aa8ef901 (patch)
tree06af7491abdf9743014e3392a1ea1189ce470c97 /tests/auto/cmake/mockplugins/CMakeLists.txt
parenta92c202b49777696cbc64003f6292e6b61952140 (diff)
Introduce the qt_internal_project_setup macro
The macro sets the required CMake variables and policies and should be called right after the find_package(Qt6 COMPONENTS BuildInternals... call to make sure that the subsequent code adopt all the required policies. Pick-to: 6.5 Task-number: QTBUG-112685 Change-Id: I9f93f728ee4d8ae7743db9fffafa26025c76dcf2 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/cmake/mockplugins/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/mockplugins/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/tests/auto/cmake/mockplugins/CMakeLists.txt b/tests/auto/cmake/mockplugins/CMakeLists.txt
index 0711631dec..dd246ed0ff 100644
--- a/tests/auto/cmake/mockplugins/CMakeLists.txt
+++ b/tests/auto/cmake/mockplugins/CMakeLists.txt
@@ -12,6 +12,8 @@ project(QtMockPlugins
)
find_package(Qt6 ${PROJECT_VERSION} CONFIG REQUIRED COMPONENTS BuildInternals Core)
+qt_internal_project_setup()
+
find_package(Qt6 ${PROJECT_VERSION} QUIET CONFIG OPTIONAL_COMPONENTS Gui Widgets Xml)
qt_build_repo_begin()