summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/pass1/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <stephen.kelly@kdab.com>2012-05-13 19:52:13 +0200
committerQt by Nokia <qt-info@nokia.com>2012-05-14 04:35:01 +0200
commitc18a41197f5df3d66dccf86c176e5dd6fd01b163 (patch)
treed45229cd4a56deea7020c1d79797450ef7d71aa6 /tests/auto/cmake/pass1/CMakeLists.txt
parentdd38ad600ff85f40dd33499f24c5b88541e2acf2 (diff)
Find Qt5 modules automatically in the qt5_use_modules function.
This ensures that we only find Qt5 modules from the same directory as modules we have already found, not from multiple different directories which may be incompatible. Change-Id: I7ad1d81ec41bba2e543130740041338ba44a6c3b Reviewed-by: Alexander Neundorf <neundorf@kde.org> Reviewed-by: Stephen Kelly <stephen.kelly@kdab.com>
Diffstat (limited to 'tests/auto/cmake/pass1/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/pass1/CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/tests/auto/cmake/pass1/CMakeLists.txt b/tests/auto/cmake/pass1/CMakeLists.txt
index d8efadc8ed..50a3375a15 100644
--- a/tests/auto/cmake/pass1/CMakeLists.txt
+++ b/tests/auto/cmake/pass1/CMakeLists.txt
@@ -10,8 +10,7 @@ set(CMAKE_INCLUDE_CURRENT_DIR ON)
add_executable(two two.cpp)
add_executable(three three.cpp)
-find_package(Qt5Test)
-find_package(Qt5Widgets)
+find_package(Qt5Core)
qt5_use_modules(two Test)
qt5_use_modules(three Widgets Test)