summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/test_QTBUG-63422/CMakeLists.txt
diff options
context:
space:
mode:
authorKyle Edwards <kyle.edwards@kitware.com>2018-10-17 16:03:28 -0400
committerAlexandru Croitor <alexandru.croitor@qt.io>2019-08-07 22:08:59 +0200
commitbf99c4bf553ea750f68745133960084f0b4c0490 (patch)
tree826af1e77f3ba57f35f951d4d4b79eac6007938e /tests/auto/cmake/test_QTBUG-63422/CMakeLists.txt
parent739b3bfb2fa54aefb14971cefc67eff2dc7aa406 (diff)
CMake: Fix some failing cmake tests
Change-Id: I74f2bf270726feba8367ea222a3c669110c99e08 Reviewed-by: Simon Hausmann <simon.hausmann@qt.io>
Diffstat (limited to 'tests/auto/cmake/test_QTBUG-63422/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/test_QTBUG-63422/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/tests/auto/cmake/test_QTBUG-63422/CMakeLists.txt b/tests/auto/cmake/test_QTBUG-63422/CMakeLists.txt
index a0b82caee4..b9b9756699 100644
--- a/tests/auto/cmake/test_QTBUG-63422/CMakeLists.txt
+++ b/tests/auto/cmake/test_QTBUG-63422/CMakeLists.txt
@@ -1,6 +1,9 @@
cmake_minimum_required(VERSION 2.8)
project(test_dependent_modules)
+# Need to set the policy to link to qtmain.lib automatically.
+cmake_policy(SET CMP0020 NEW)
+
find_package(Qt5Widgets REQUIRED)
set(CMAKE_AUTOMOC ON)