summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/test_add_big_resource/CMakeLists.txt
diff options
context:
space:
mode:
authorJoerg Bornemann <joerg.bornemann@qt.io>2021-05-20 18:15:49 +0200
committerJoerg Bornemann <joerg.bornemann@qt.io>2021-05-22 22:32:27 +0200
commit895edcd7cdcf47ec9238d42db742f81c5c2eaeb9 (patch)
treebe46b9c41709e0ca7e8de6e57be76e283a1ae939 /tests/auto/cmake/test_add_big_resource/CMakeLists.txt
parentecbf6c5b00aca0792f0b73344f5e9810900682a7 (diff)
Support multiple equally named .qrc files in qt_add_big_resources
It is now possible to call qt_add_big_resources with multiple .qrc files that are in different directories but have the same file name. Before, this resulted in target name conflict errors. Pick-to: 6.1 Fixes: QTBUG-93230 Change-Id: Ic3d9d6974a107163aeb7ada0b6f1fa113fb18de0 Reviewed-by: Alexandru Croitor <alexandru.croitor@qt.io>
Diffstat (limited to 'tests/auto/cmake/test_add_big_resource/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/test_add_big_resource/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/tests/auto/cmake/test_add_big_resource/CMakeLists.txt b/tests/auto/cmake/test_add_big_resource/CMakeLists.txt
index 49abde6650..59e5705925 100644
--- a/tests/auto/cmake/test_add_big_resource/CMakeLists.txt
+++ b/tests/auto/cmake/test_add_big_resource/CMakeLists.txt
@@ -9,7 +9,8 @@ find_package(Qt6Core REQUIRED)
qt_wrap_cpp(moc_files myobject.h)
-qt_add_big_resources(rcc_files "test_add_big_resource.qrc" "test_add_big_resource2.qrc")
+qt_add_big_resources(rcc_files "test_add_big_resource.qrc" "test_add_big_resource2.qrc"
+ "subdir/test_add_big_resource.qrc")
add_executable(myobject myobject.cpp ${moc_files} ${rcc_files})
target_link_libraries(myobject PRIVATE Qt::Core)