summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/test_multiple_find_package/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <stephen.kelly@kdab.com>2013-02-19 20:00:28 +0100
committerThe Qt Project <gerrit-noreply@qt-project.org>2013-02-21 22:41:05 +0100
commit7477d50fce9a0008ff4e050285e146ebc0c1e163 (patch)
treee52f377df3918f00c32d509a76639eee0b56f0f0 /tests/auto/cmake/test_multiple_find_package/CMakeLists.txt
parent057fabab7cbcb6b278771e1336c3a82f64106b2d (diff)
Populate the cmake variables only one time.
Since we're only including the Extras file one time, invoking set() for the include dirs again will overwrite the addition of include dirs in the extras file. We only need to populate these variables if not set anyway, so do that. Change-Id: I04dad0674778e79c8c12c18231b8ce6c92edf881 Reviewed-by: Alexander Neundorf <neundorf@kde.org> Reviewed-by: Stephen Kelly <stephen.kelly@kdab.com>
Diffstat (limited to 'tests/auto/cmake/test_multiple_find_package/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/test_multiple_find_package/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/tests/auto/cmake/test_multiple_find_package/CMakeLists.txt b/tests/auto/cmake/test_multiple_find_package/CMakeLists.txt
index dfac4ca3be..c0fdfd6b9a 100644
--- a/tests/auto/cmake/test_multiple_find_package/CMakeLists.txt
+++ b/tests/auto/cmake/test_multiple_find_package/CMakeLists.txt
@@ -5,5 +5,9 @@ project(test_multiple_find_package)
find_package(Qt5Core REQUIRED)
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Core_EXECUTABLE_COMPILE_FLAGS}")
+
add_subdirectory(subdir1)
+add_executable(exe1 "${CMAKE_CURRENT_SOURCE_DIR}/main.cpp")
+include_directories(${Qt5Core_INCLUDE_DIRS})