summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/test_private_includes/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <stephen.kelly@kdab.com>2012-06-22 19:18:45 +0200
committerQt by Nokia <qt-info@nokia.com>2012-06-23 14:16:24 +0200
commit3d2a8d09d1444ce659abdc257b7f074b4472b7d7 (patch)
treea57dbe45bc8fe40cf1009fb9301e280cbbe66f31 /tests/auto/cmake/test_private_includes/CMakeLists.txt
parent2af438a6ce31f225f0d1c0b1b43df848a858fe18 (diff)
Add a variable for the private includes for modules.
This is required to use QPA for example in 5.0. Change-Id: I44bfc6987d778370e55c05c591f63ff84c482d0a Reviewed-by: David Faure <faure@kde.org>
Diffstat (limited to 'tests/auto/cmake/test_private_includes/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/test_private_includes/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/tests/auto/cmake/test_private_includes/CMakeLists.txt b/tests/auto/cmake/test_private_includes/CMakeLists.txt
new file mode 100644
index 0000000000..f283bc21b3
--- /dev/null
+++ b/tests/auto/cmake/test_private_includes/CMakeLists.txt
@@ -0,0 +1,18 @@
+
+cmake_minimum_required(VERSION 2.8)
+
+project(test_private_includes)
+
+find_package(Qt5Gui REQUIRED)
+
+include_directories(
+ ${Qt5Gui_INCLUDE_DIRS}
+ ${Qt5Gui_PRIVATE_INCLUDE_DIRS}
+)
+
+add_definitions(${Qt5Gui_DEFINITIONS})
+
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${Qt5Gui_EXECUTABLE_COMPILE_FLAGS}")
+
+add_executable(testapp main.cpp)
+target_link_libraries(testapp ${Qt5Gui_LIBRARIES})