summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/test_testlib_definitions/CMakeLists.txt
diff options
context:
space:
mode:
authorStephen Kelly <stephen.kelly@kdab.com>2013-03-14 14:08:55 +0100
committerThe Qt Project <gerrit-noreply@qt-project.org>2013-03-18 20:17:10 +0100
commit4111a676f1073e2f29de2c042785a941dbfb9458 (patch)
tree5750889bd6cf75766d511f8a879129040f14a6c3 /tests/auto/cmake/test_testlib_definitions/CMakeLists.txt
parent374fc337ae03b44903768c18eb3f16c0e5451f81 (diff)
Make the qtbase cmake tests work without the Widgets module.
Task-number: QTBUG-28540 Change-Id: I916d104c8aba551ee9a5b34da3fd85dcb26bbf64 Reviewed-by: Alexander Neundorf <neundorf@kde.org> Reviewed-by: Stephen Kelly <stephen.kelly@kdab.com>
Diffstat (limited to 'tests/auto/cmake/test_testlib_definitions/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/test_testlib_definitions/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/auto/cmake/test_testlib_definitions/CMakeLists.txt b/tests/auto/cmake/test_testlib_definitions/CMakeLists.txt
index c370e8effa..cc54bf5bc3 100644
--- a/tests/auto/cmake/test_testlib_definitions/CMakeLists.txt
+++ b/tests/auto/cmake/test_testlib_definitions/CMakeLists.txt
@@ -35,4 +35,6 @@ endmacro()
add_subdirectory(core_only)
add_subdirectory(gui)
-add_subdirectory(widgets)
+if(NOT NO_WIDGETS)
+ add_subdirectory(widgets)
+endif()