summaryrefslogtreecommitdiffstats
path: root/tests/auto/cmake/test_testlib_definitions/CMakeLists.txt
diff options
context:
space:
mode:
authorKai Pastor <dg0yt@darc.de>2016-03-23 19:26:02 +0100
committerKai Pastor <dg0yt@darc.de>2016-03-30 07:16:50 +0000
commit9bc352e38d6b03fbb12a359a7bdfc8d22aa7e192 (patch)
treeb07bafc34b90921db205995f676fc7dfe60b5574 /tests/auto/cmake/test_testlib_definitions/CMakeLists.txt
parent8875e9fe825f3f4d39a25fe29006245f4801e595 (diff)
Enable cmake auto tests for -no-gui
This change disables tests which require QtGui. Change-Id: Ib647afd086f54536054cb4c0cde5696d762ee8c4 Reviewed-by: Stephen Kelly <steveire@gmail.com> Reviewed-by: Kevin Funk <kevin.funk@kdab.com>
Diffstat (limited to 'tests/auto/cmake/test_testlib_definitions/CMakeLists.txt')
-rw-r--r--tests/auto/cmake/test_testlib_definitions/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/tests/auto/cmake/test_testlib_definitions/CMakeLists.txt b/tests/auto/cmake/test_testlib_definitions/CMakeLists.txt
index cc54bf5bc3..6fe7e56d24 100644
--- a/tests/auto/cmake/test_testlib_definitions/CMakeLists.txt
+++ b/tests/auto/cmake/test_testlib_definitions/CMakeLists.txt
@@ -34,7 +34,9 @@ macro(test_testlib_project _module)
endmacro()
add_subdirectory(core_only)
-add_subdirectory(gui)
+if(NOT NO_GUI)
+ add_subdirectory(gui)
+endif()
if(NOT NO_WIDGETS)
add_subdirectory(widgets)
endif()